aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorGediminas Liktaras <gliktaras@gmail.com>2011-12-08 13:34:09 (GMT)
committerPaul Tagliamonte <paultag@fluxbox.org>2011-12-10 16:13:19 (GMT)
commitcd339169d1961eb508ea89cee2609ec6d0fc0c15 (patch)
tree01acd158a03fb17a72e067ff0b36701da75e49dc /util/Makefile.am
parent85ac5c4b2c6a526992f483a6e91867dc2f82a19e (diff)
downloadfluxbox_paul-cd339169d1961eb508ea89cee2609ec6d0fc0c15.zip
fluxbox_paul-cd339169d1961eb508ea89cee2609ec6d0fc0c15.tar.bz2
fbcompose - A compositing addon for fluxbox window manager.
fbcompose(1) is an optional compositing addon for fluxbox window manager. It augments fluxbox with a number of graphical features. Most notably, fbcompose allows fluxbox to properly display applications that require compositing (docky, for example), adds support for true window transparency (as opposed to fluxbox's pseudo transparency) and provides a plugin framework to extend the compositor's functionality. As this is still a beta version of the compositor, the bugs are likely.
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am11
1 files changed, 9 insertions, 2 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index c6dbd9d..2922ecd 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -1,6 +1,13 @@
1# util/Makefile.am for Fluxbox 1# util/Makefile.am for Fluxbox
2SUBDIRS= fbrun 2if BUILD_FBCOMPOSE
3INCLUDES= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk -I$(top_srcdir)/libs/lua/src 3fbcompose_SUBDIRS=fbcompose
4else
5fbcompose_SUBDIRS=
6endif # BUILD_FBCOMPOSE
7
8SUBDIRS= $(fbcompose_SUBDIRS) fbrun
9INCLUDES= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk -I$(top_srcdir)/libs/lua/src
10
4bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox 11bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox
5bin_PROGRAMS= fbsetroot fluxbox-update_configs fluxbox-remote 12bin_PROGRAMS= fbsetroot fluxbox-update_configs fluxbox-remote
6fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh 13fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh