aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorSami Kerola <kerolasa@iki.fi>2013-02-12 22:05:45 (GMT)
committerSami Kerola <kerolasa@iki.fi>2013-05-26 09:38:10 (GMT)
commit73b79587708d49adfec3edb464fd0970fc9f9022 (patch)
tree17a8fd36635ccf8e56d5f4fa821678665348dab6 /util/Makefile.am
parentf5bfd27f524d33e9aebf502dc6c0e8ff316fed7c (diff)
downloadfluxbox-73b79587708d49adfec3edb464fd0970fc9f9022.zip
fluxbox-73b79587708d49adfec3edb464fd0970fc9f9022.tar.bz2
build-sys: include config.h to all files using automake
Do not try to be too smart which compilations need config.h, as most of them will simply because of the config.h has information about system capabilities.
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index f47924f..1123f68 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -1,6 +1,6 @@
1# util/Makefile.am for Fluxbox 1# util/Makefile.am for Fluxbox
2SUBDIRS= fbrun 2SUBDIRS= fbrun
3AM_CPPFLAGS= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk 3AM_CPPFLAGS= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk -include $(top_builddir)/config.h
4bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox 4bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox
5bin_PROGRAMS= fbsetroot fluxbox-update_configs fluxbox-remote 5bin_PROGRAMS= fbsetroot fluxbox-update_configs fluxbox-remote
6fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh 6fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh
@@ -23,10 +23,10 @@ all-local: startfluxbox
23clean-local: 23clean-local:
24 rm -f startfluxbox fluxbox-generate_menu 24 rm -f startfluxbox fluxbox-generate_menu
25 25
26fbsetroot.o: fbsetroot.cc ../config.h $(srcdir)/fbsetroot.hh \ 26fbsetroot.o: fbsetroot.cc $(srcdir)/fbsetroot.hh \
27 $(top_srcdir)/src/FbRootWindow.hh $(top_srcdir)/src/FbAtoms.hh 27 $(top_srcdir)/src/FbRootWindow.hh $(top_srcdir)/src/FbAtoms.hh
28 28
29fluxbox-update_configs.o: fluxbox-update_configs.cc ../config.h \ 29fluxbox-update_configs.o: fluxbox-update_configs.cc \
30 $(top_builddir)/src/defaults.hh 30 $(top_builddir)/src/defaults.hh
31 31
32fluxbox-remote.o: fluxbox-remote.cc 32fluxbox-remote.o: fluxbox-remote.cc