aboutsummaryrefslogtreecommitdiff
path: root/src/FbTk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/FbTk/Makefile.am')
-rw-r--r--src/FbTk/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/FbTk/Makefile.am b/src/FbTk/Makefile.am
index 1f93e98..5146810 100644
--- a/src/FbTk/Makefile.am
+++ b/src/FbTk/Makefile.am
@@ -2,6 +2,7 @@ noinst_LIBRARIES = libFbTk.a
2 2
3AM_CPPFLAGS=@CPPFLAGS@ 3AM_CPPFLAGS=@CPPFLAGS@
4INCLUDES = -I$(top_srcdir)/libs/lua/src 4INCLUDES = -I$(top_srcdir)/libs/lua/src
5CLEANFILES = LResourceHelper-lua.cc LResourceHelper.luac
5 6
6if XFT 7if XFT
7xft_SOURCE= XftFontImp.hh XftFontImp.cc 8xft_SOURCE= XftFontImp.hh XftFontImp.cc
@@ -65,8 +66,15 @@ libFbTk_a_SOURCES = App.hh App.cc Color.cc Color.hh Command.hh \
65 CachedPixmap.hh CachedPixmap.cc \ 66 CachedPixmap.hh CachedPixmap.cc \
66 Slot.hh Signal.hh MemFun.hh SelectArg.hh \ 67 Slot.hh Signal.hh MemFun.hh SelectArg.hh \
67 Util.hh \ 68 Util.hh \
68 Luamm.cc Luamm.hh \ 69 Luamm.cc Luamm.hh LResource.cc LResource.hh LResourceHelper-lua.cc \
69 ${xpm_SOURCE} \ 70 ${xpm_SOURCE} \
70 ${xft_SOURCE} \ 71 ${xft_SOURCE} \
71 ${xmb_SOURCE} \ 72 ${xmb_SOURCE} \
72 $(imlib2_SOURCE) 73 $(imlib2_SOURCE)
74
75%.luac: %.lua Makefile
76 $(top_builddir)/libs/lua/src/luac -o $@ $<
77
78
79%-lua.cc: %.luac $(top_srcdir)/luatoc.sh Makefile
80 $(top_srcdir)/luatoc.sh $< $@ $(<:.luac=)