aboutsummaryrefslogtreecommitdiff
path: root/src/FbTk/Makefile.am
diff options
context:
space:
mode:
authorPavel Labath <pavelo@centrum.sk>2011-06-05 12:27:13 (GMT)
committerPavel Labath <pavelo@centrum.sk>2011-11-01 09:52:46 (GMT)
commitfc21fd822e527dbd918c6565e0e2cea82b0466f4 (patch)
treeb658bf437fafb80d39986c77caebcaf608761964 /src/FbTk/Makefile.am
parente3fabc4cd47ac5479bca421a4d7b79c0c2d9e120 (diff)
downloadfluxbox_pavel-fc21fd822e527dbd918c6565e0e2cea82b0466f4.zip
fluxbox_pavel-fc21fd822e527dbd918c6565e0e2cea82b0466f4.tar.bz2
A rough version of resource implementation in lua
I added a new class, LResourceManager, which should handle loading and saving of resources like the old ResourceManager, only it does that with the help of lua. I moved the common features of the two managers (interface + a few functions) to a common base class ResourceManager_base. I augmented the Resource_base class with two new functions (setFromLua and pushToLua) which are used by the lua RM instead of getString and setFromString. Parts of the new RM are written in lua. To avoid loading scripts from a file at runtime I decided to link compiled lua code straight into the executable. For this purpose I created a small script which converts a binary file into a declaration of a C array of bytes.
Diffstat (limited to 'src/FbTk/Makefile.am')
-rw-r--r--src/FbTk/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/src/FbTk/Makefile.am b/src/FbTk/Makefile.am
index 1f93e98..5146810 100644
--- a/src/FbTk/Makefile.am
+++ b/src/FbTk/Makefile.am
@@ -2,6 +2,7 @@ noinst_LIBRARIES = libFbTk.a
2 2
3AM_CPPFLAGS=@CPPFLAGS@ 3AM_CPPFLAGS=@CPPFLAGS@
4INCLUDES = -I$(top_srcdir)/libs/lua/src 4INCLUDES = -I$(top_srcdir)/libs/lua/src
5CLEANFILES = LResourceHelper-lua.cc LResourceHelper.luac
5 6
6if XFT 7if XFT
7xft_SOURCE= XftFontImp.hh XftFontImp.cc 8xft_SOURCE= XftFontImp.hh XftFontImp.cc
@@ -65,8 +66,15 @@ libFbTk_a_SOURCES = App.hh App.cc Color.cc Color.hh Command.hh \
65 CachedPixmap.hh CachedPixmap.cc \ 66 CachedPixmap.hh CachedPixmap.cc \
66 Slot.hh Signal.hh MemFun.hh SelectArg.hh \ 67 Slot.hh Signal.hh MemFun.hh SelectArg.hh \
67 Util.hh \ 68 Util.hh \
68 Luamm.cc Luamm.hh \ 69 Luamm.cc Luamm.hh LResource.cc LResource.hh LResourceHelper-lua.cc \
69 ${xpm_SOURCE} \ 70 ${xpm_SOURCE} \
70 ${xft_SOURCE} \ 71 ${xft_SOURCE} \
71 ${xmb_SOURCE} \ 72 ${xmb_SOURCE} \
72 $(imlib2_SOURCE) 73 $(imlib2_SOURCE)
74
75%.luac: %.lua Makefile
76 $(top_builddir)/libs/lua/src/luac -o $@ $<
77
78
79%-lua.cc: %.luac $(top_srcdir)/luatoc.sh Makefile
80 $(top_srcdir)/luatoc.sh $< $@ $(<:.luac=)