aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in40
1 files changed, 20 insertions, 20 deletions
diff --git a/configure.in b/configure.in
index 6e4a53c..71c86d1 100644
--- a/configure.in
+++ b/configure.in
@@ -60,10 +60,10 @@ AC_FUNC_REALLOC
60AC_FUNC_SELECT_ARGTYPES 60AC_FUNC_SELECT_ARGTYPES
61AC_FUNC_STAT 61AC_FUNC_STAT
62 62
63AC_CHECK_FUNCS(basename, , AC_CHECK_LIB(gen, basename, LIBS="$LIBS -lgen")) 63AC_CHECK_FUNCS(basename, , AC_CHECK_LIB(gen, basename, LIBS="-lgen $LIBS"))
64AC_CHECK_FUNCS(catclose catgets catopen getpid gettimeofday memset mkdir \ 64AC_CHECK_FUNCS(catclose catgets catopen getpid gettimeofday memset mkdir \
65 nl_langinfo putenv regcomp select setenv setlocale sigaction snprintf \ 65 nl_langinfo putenv regcomp select setenv setlocale sigaction snprintf \
66 sqrt strcasecmp strcasestr strchr strstr strtol strtoul vsnprintf) 66 sqrt strcasecmp strcasestr strchr strstr strtol strtoul sync vsnprintf)
67 67
68dnl The autoconf test for strftime is broken now (due to gcc 3.3 bug?): 68dnl The autoconf test for strftime is broken now (due to gcc 3.3 bug?):
69dnl Gcc 3.3 testprog = ``extern "C" char strftime;'', build with g++ test.cc 69dnl Gcc 3.3 testprog = ``extern "C" char strftime;'', build with g++ test.cc
@@ -130,13 +130,13 @@ if test "x$ac_cv_header_iconv_h" = "xyes"; then
130 AC_CHECK_LIB([iconv], 130 AC_CHECK_LIB([iconv],
131 [iconv_open], 131 [iconv_open],
132 [ 132 [
133 LIBS="$LIBS -liconv" 133 LIBS="-liconv $LIBS"
134 ], 134 ],
135 []) 135 [])
136 AC_CHECK_LIB([iconv], 136 AC_CHECK_LIB([iconv],
137 [libiconv_open], 137 [libiconv_open],
138 [ 138 [
139 LIBS="$LIBS -liconv" 139 LIBS="-liconv $LIBS"
140 ], 140 ],
141 []) 141 [])
142 142
@@ -163,8 +163,8 @@ dnl Check if iconv uses const in prototype declaration
163 fi 163 fi
164fi 164fi
165 165
166AC_CHECK_LIB(nsl, t_open, LIBS="$LIBS -lnsl") 166AC_CHECK_LIB(nsl, t_open, LIBS="-lnsl $LIBS")
167AC_CHECK_LIB(socket, socket, LIBS="$LIBS -lsocket") 167AC_CHECK_LIB(socket, socket, LIBS="-lsocket $LIBS")
168 168
169dnl Check for X headers and libraries 169dnl Check for X headers and libraries
170AC_PATH_X 170AC_PATH_X
@@ -177,18 +177,18 @@ test x$x_libraries = "x" && x_libraries="/usr/lib"
177 177
178CFLAGS="$CFLAGS $X_CFLAGS" 178CFLAGS="$CFLAGS $X_CFLAGS"
179CXXFLAGS="$CXXFLAGS $X_CFLAGS" 179CXXFLAGS="$CXXFLAGS $X_CFLAGS"
180LIBS="$LIBS $X_LIBS" 180LIBS="$X_LIBS $LIBS"
181LDFLAGS="$LDFLAGS $LIBS $X_PRE_LIBS" 181LDFLAGS="$LDFLAGS $LIBS $X_PRE_LIBS"
182 182
183 183
184dnl Check for required functions in -lX11 184dnl Check for required functions in -lX11
185AC_CHECK_LIB(X11, XOpenDisplay, 185AC_CHECK_LIB(X11, XOpenDisplay,
186 LIBS="$LIBS -lX11", 186 LIBS="-lX11 $LIBS",
187 AC_MSG_ERROR([Could not find XOpenDisplay in -lX11.]) 187 AC_MSG_ERROR([Could not find XOpenDisplay in -lX11.])
188) 188)
189LIBS="$LIBS $X_EXTRA_LIBS" 189LIBS="$X_EXTRA_LIBS $LIBS"
190 190
191AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4") 191AC_CHECK_LIB(xpg4, setlocale, LIBS="-lxpg4 $LIBS")
192 192
193AC_CHECK_PROGS(gencat_cmd, gencat) 193AC_CHECK_PROGS(gencat_cmd, gencat)
194if test x$gencat_cmd = "x"; then 194if test x$gencat_cmd = "x"; then
@@ -397,14 +397,14 @@ AC_ARG_ENABLE(
397 AC_MSG_RESULT([yes]) 397 AC_MSG_RESULT([yes])
398 AC_CHECK_LIB(Xrender, XRenderCreatePicture, 398 AC_CHECK_LIB(Xrender, XRenderCreatePicture,
399 AC_DEFINE(HAVE_XRENDER, 1, "Xrender support") 399 AC_DEFINE(HAVE_XRENDER, 1, "Xrender support")
400 LIBS="$LIBS -lXrender") 400 LIBS="-lXrender $LIBS")
401 else 401 else
402 AC_MSG_RESULT([no]) 402 AC_MSG_RESULT([no])
403 fi, 403 fi,
404 AC_MSG_RESULT([yes]) 404 AC_MSG_RESULT([yes])
405 AC_CHECK_LIB(Xrender, XRenderCreatePicture, 405 AC_CHECK_LIB(Xrender, XRenderCreatePicture,
406 AC_DEFINE(HAVE_XRENDER, 1, "Xrender support") 406 AC_DEFINE(HAVE_XRENDER, 1, "Xrender support")
407 LIBS="$LIBS -lXrender") 407 LIBS="-lXrender $LIBS")
408) 408)
409 409
410XPM=false 410XPM=false
@@ -417,7 +417,7 @@ AC_ARG_ENABLE(
417 AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, 417 AC_CHECK_LIB(Xpm, XpmReadFileToPixmap,
418 AC_DEFINE(HAVE_XPM, 1, "Xpm support") 418 AC_DEFINE(HAVE_XPM, 1, "Xpm support")
419 XPM=true 419 XPM=true
420 LIBS="$LIBS -lXpm") 420 LIBS="-lXpm $LIBS")
421 else 421 else
422 AC_MSG_RESULT([no]) 422 AC_MSG_RESULT([no])
423 fi, 423 fi,
@@ -425,7 +425,7 @@ AC_ARG_ENABLE(
425 AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, 425 AC_CHECK_LIB(Xpm, XpmReadFileToPixmap,
426 AC_DEFINE(HAVE_XPM, 1, "Xpm support") 426 AC_DEFINE(HAVE_XPM, 1, "Xpm support")
427 XPM=true 427 XPM=true
428 LIBS="$LIBS -lXpm") 428 LIBS="-lXpm $LIBS")
429) 429)
430 430
431AM_CONDITIONAL(XPM, test x$XPM = xtrue) 431AM_CONDITIONAL(XPM, test x$XPM = xtrue)
@@ -445,7 +445,7 @@ if test x$enable_imlib2 = "xyes"; then
445 AC_DEFINE(HAVE_IMLIB2, [], [Imlib2 support]) 445 AC_DEFINE(HAVE_IMLIB2, [], [Imlib2 support])
446 IMLIB2_LIBS=`imlib2-config --libs` 446 IMLIB2_LIBS=`imlib2-config --libs`
447 IMLIB2_CFLAGS=`imlib2-config --cflags` 447 IMLIB2_CFLAGS=`imlib2-config --cflags`
448 LIBS="$LIBS $IMLIB2_LIBS" 448 LIBS="$IMLIB2_LIBS $LIBS"
449 CXXFLAGS="$CXXFLAGS $IMLIB2_CFLAGS" 449 CXXFLAGS="$CXXFLAGS $IMLIB2_CFLAGS"
450 ], [ AC_MSG_RESULT(no)] 450 ], [ AC_MSG_RESULT(no)]
451 ) 451 )
@@ -494,7 +494,7 @@ if test "x$enableval" = "xyes"; then
494 , XineramaQueryScreens(0, 0), 494 , XineramaQueryScreens(0, 0),
495 AC_MSG_RESULT([yes]) 495 AC_MSG_RESULT([yes])
496 AC_DEFINE(XINERAMA, [1], [Define to 1 if you have XINERAMA]) 496 AC_DEFINE(XINERAMA, [1], [Define to 1 if you have XINERAMA])
497 LIBS="$LIBS -lXinerama", 497 LIBS="-lXinerama $LIBS",
498 AC_MSG_RESULT([no]))) 498 AC_MSG_RESULT([no])))
499else 499else
500 AC_MSG_RESULT([no]) 500 AC_MSG_RESULT([no])
@@ -519,7 +519,7 @@ if test "x$enableval" = "xyes"; then
519 , long foo = ShapeSet, 519 , long foo = ShapeSet,
520 AC_MSG_RESULT([yes]) 520 AC_MSG_RESULT([yes])
521 AC_DEFINE(SHAPE, [1], [Define to 1 if you have SHAPE]) 521 AC_DEFINE(SHAPE, [1], [Define to 1 if you have SHAPE])
522 LIBS="$LIBS -lXext" 522 LIBS="-lXext $LIBS"
523 FEATURES="$FEATURES XShape", 523 FEATURES="$FEATURES XShape",
524 AC_MSG_RESULT([no]))) 524 AC_MSG_RESULT([no])))
525else 525else
@@ -547,7 +547,7 @@ if test "x$enableval" = "xyes"; then
547 , XRRQueryExtension(0, 0, 0), 547 , XRRQueryExtension(0, 0, 0),
548 AC_MSG_RESULT([yes]) 548 AC_MSG_RESULT([yes])
549 AC_DEFINE(HAVE_RANDR, [1], [Define to 1 if you have RANDR]) 549 AC_DEFINE(HAVE_RANDR, [1], [Define to 1 if you have RANDR])
550 LIBS="$LIBS -lXrandr", 550 LIBS="-lXrandr $LIBS",
551 AC_MSG_RESULT([no]))) 551 AC_MSG_RESULT([no])))
552else 552else
553 AC_MSG_RESULT([no]) 553 AC_MSG_RESULT([no])
@@ -571,7 +571,7 @@ if test "x$enableval" = "xyes"; then
571 , XRRUpdateConfiguration(0), 571 , XRRUpdateConfiguration(0),
572 AC_MSG_RESULT([yes]) 572 AC_MSG_RESULT([yes])
573 AC_DEFINE(HAVE_RANDR1_2, [1], [Define to 1 if you have RANDR 1.2]) 573 AC_DEFINE(HAVE_RANDR1_2, [1], [Define to 1 if you have RANDR 1.2])
574 LIBS="$LIBS -lXrandr", 574 LIBS="-lXrandr $LIBS",
575 AC_MSG_RESULT([no]))) 575 AC_MSG_RESULT([no])))
576else 576else
577 AC_MSG_RESULT([no]) 577 AC_MSG_RESULT([no])
@@ -613,7 +613,7 @@ if test "x$enableval" = "xyes"; then
613 , fribidi_version_info, 613 , fribidi_version_info,
614 AC_MSG_RESULT([yes]) 614 AC_MSG_RESULT([yes])
615 AC_DEFINE(HAVE_FRIBIDI, [1], [Define to 1 if you have FRIBIDI]) 615 AC_DEFINE(HAVE_FRIBIDI, [1], [Define to 1 if you have FRIBIDI])
616 LIBS="$LIBS -lfribidi", 616 LIBS="-lfribidi $LIBS",
617 AC_MSG_RESULT([no]))) 617 AC_MSG_RESULT([no])))
618else 618else
619 AC_MSG_RESULT([no]) 619 AC_MSG_RESULT([no])