aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in23
1 files changed, 11 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index c525f64..604c5eb 100644
--- a/configure.in
+++ b/configure.in
@@ -96,18 +96,17 @@ if test "x$ac_found_iconv" = "xyes"; then
96 AC_CACHE_CHECK(for iconv declaration, ac_cv_iconv_const, 96 AC_CACHE_CHECK(for iconv declaration, ac_cv_iconv_const,
97 [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <stdlib.h> 97 [AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <stdlib.h>
98 #include <iconv.h>]], 98 #include <iconv.h>]],
99 [[#ifdef __cplusplus 99 [[
100 "C" 100 char **msg, **new_msg;
101 #endif 101 size_t result, inleft, outleft;
102 #if defined(__STDC__) || defined(__cplusplus) 102 result = iconv((iconv_t)(-1), msg, &inleft, new_msg, &outleft);
103 size_t iconv (iconv_t cd, char * *inbuf, size_t *inbytesleft, char * *outbuf, size_t *outbytesleft); 103 return 0;
104 #else 104 ]])],
105 size_t iconv(); 105 [ac_cv_iconv_const=no],
106 #endif]])], 106 [ac_cv_iconv_const=yes])])
107 [ac_cv_iconv_const=], 107 if test "x$ac_cv_iconv_const" = xyes; then
108 [ac_cv_iconv_const=const])]) 108 AC_DEFINE(HAVE_CONST_ICONV, 1, [Define if you have the iconv() function.])
109 AC_DEFINE_UNQUOTED([HAVE_CONST_ICONV], $ac_cv_iconv_const, 109 fi
110 [Define as const if the declaration of iconv() needs const.])
111fi 110fi
112 111
113 112