diff options
Diffstat (limited to 'configure.ac')
-rw-r--r-- | configure.ac | 14 |
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac index 226510d..cd6816f 100644 --- a/configure.ac +++ b/configure.ac | |||
@@ -265,11 +265,23 @@ AS_IF(test "x$enable_slit" = "xyes",[AC_DEFINE(USE_SLIT, 1, " compile with slit" | |||
265 | AM_CONDITIONAL(SLIT_SRC, test "x$enable_slit" = "xyes") | 265 | AM_CONDITIONAL(SLIT_SRC, test "x$enable_slit" = "xyes") |
266 | 266 | ||
267 | 267 | ||
268 | |||
269 | dnl Check for Systemtray options | ||
270 | AC_MSG_CHECKING([whether to include SystemTray]) | ||
271 | AC_ARG_ENABLE(systray, | ||
272 | AS_HELP_STRING([--enable-systray],[include SystemTray (default=yes)]),,[enable_systray=yes]) | ||
273 | AC_MSG_RESULT([$enable_systray]) | ||
274 | AS_IF(test "x$enable_systray" = "xyes",[AC_DEFINE(USE_SYSTRAY, 1, " compile with systemtray")],[]) | ||
275 | AM_CONDITIONAL(SYSTRAY_SRC, test "x$enable_systray" = "xyes") | ||
276 | |||
268 | dnl Check for Toolbar options | 277 | dnl Check for Toolbar options |
269 | AC_MSG_CHECKING([whether to include Toolbar]) | 278 | AC_MSG_CHECKING([whether to include Toolbaddr]) |
270 | AC_ARG_ENABLE(toolbar, | 279 | AC_ARG_ENABLE(toolbar, |
271 | AS_HELP_STRING([--enable-toolbar],[include Toolbar (default=yes)]),,[enable_toolbar=yes]) | 280 | AS_HELP_STRING([--enable-toolbar],[include Toolbar (default=yes)]),,[enable_toolbar=yes]) |
272 | AC_MSG_RESULT([$enable_toolbar]) | 281 | AC_MSG_RESULT([$enable_toolbar]) |
282 | AS_IF(test "x$enable_systray" = "xyes" -a "x$enable_toolbar" != "xyes",[ | ||
283 | AC_MSG_RESULT([disabled toolbar, but enabled systray => reenable toolbar]) | ||
284 | AS_VAR_SET(enable_toolbar, "yes")],[]) | ||
273 | AS_IF(test "x$enable_toolbar" = "xyes",[AC_DEFINE(USE_TOOLBAR, 1, " compile with toolbar")],[]) | 285 | AS_IF(test "x$enable_toolbar" = "xyes",[AC_DEFINE(USE_TOOLBAR, 1, " compile with toolbar")],[]) |
274 | AM_CONDITIONAL(TOOLBAR_SRC, test "x$enable_toolbar" = "xyes") | 286 | AM_CONDITIONAL(TOOLBAR_SRC, test "x$enable_toolbar" = "xyes") |
275 | 287 | ||