aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMark Tiefenbruck <mark@fluxbox.org>2007-12-28 20:55:51 (GMT)
committerMark Tiefenbruck <mark@fluxbox.org>2007-12-28 20:55:51 (GMT)
commite90c3678d9e54bc9251619fdee2d7341f042167b (patch)
tree6f6aa45158ddf1b922acda2316463c04927db5c8 /configure.in
parent8e96ffb74b98b08ac35dcd1c861421c65a55cbe6 (diff)
downloadfluxbox_pavel-e90c3678d9e54bc9251619fdee2d7341f042167b.zip
fluxbox_pavel-e90c3678d9e54bc9251619fdee2d7341f042167b.tar.bz2
move #define SHAPE to config.h instead of -DSHAPE on command line
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 12 insertions, 21 deletions
diff --git a/configure.in b/configure.in
index 6e6e7d0..99889fa 100644
--- a/configure.in
+++ b/configure.in
@@ -178,32 +178,23 @@ fi
178Xext_lib="" 178Xext_lib=""
179 179
180dnl Check for XShape extension support and proper library files. 180dnl Check for XShape extension support and proper library files.
181SHAPE=""
182AC_MSG_CHECKING([whether to build support for the XShape extension]) 181AC_MSG_CHECKING([whether to build support for the XShape extension])
183AC_ARG_ENABLE( 182AC_ARG_ENABLE(
184 shape, [ --enable-shape enable support of the XShape extension ([default=yes])]) 183 shape, [ --enable-shape enable support of the XShape extension ([default=yes])],
184 if test x$enableval = "xyes"; then
185 AC_MSG_RESULT([yes])
186 AC_CHECK_LIB(Xext, XShapeCombineShape,
187 AC_DEFINE(SHAPE, 1, "shaped window support")
188 LIBS="$LIBS -lXext")
189 else
190 AC_MSG_RESULT([no])
191 fi,
185 192
186: ${enableval="yes"}
187if test x$enableval = "xyes"; then
188 AC_MSG_RESULT([yes]) 193 AC_MSG_RESULT([yes])
189 AC_CHECK_LIB(Xext, XShapeCombineShape, 194 AC_CHECK_LIB(Xext, XShapeCombineShape,
190 AC_MSG_CHECKING([for X11/extensions/shape.h]) 195 AC_DEFINE(SHAPE, 1, "shaped window support")
191 AC_TRY_LINK( 196 LIBS="$LIBS -lXext")
192#include <X11/Xlib.h> 197)
193#include <X11/Xutil.h>
194#include <X11/extensions/shape.h>
195, long foo = ShapeSet,
196 AC_MSG_RESULT([yes])
197 SHAPE="-DSHAPE"; Xext_lib="-lXext",
198 AC_MSG_RESULT([no])
199 )
200 )
201else
202 AC_MSG_RESULT([no])
203fi
204AC_SUBST(SHAPE)
205CXXFLAGS="$CXXFLAGS $SHAPE"
206LIBS="$LIBS $Xext_lib"
207 198
208dnl Check for the Slit 199dnl Check for the Slit
209AC_MSG_CHECKING([whether to include the Slit]) 200AC_MSG_CHECKING([whether to include the Slit])