aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPavel Labath <pavelo@centrum.sk>2011-04-19 20:42:36 (GMT)
committerMathias Gumz <akira at fluxbox dot org>2011-05-07 10:39:04 (GMT)
commitde2cca8988f43443f83f6f324c73d6ea03edfae3 (patch)
treebc8e33d8330e032d9fbcef2d801155f51b1fef99 /configure.in
parent127ec08ae6bffeefedd06b73aea4ee2fa2bd265b (diff)
downloadfluxbox_pavel-de2cca8988f43443f83f6f324c73d6ea03edfae3.zip
fluxbox_pavel-de2cca8988f43443f83f6f324c73d6ea03edfae3.tar.bz2
Include src/tests in the distribution tarball
and add a configure option for building them (default: off). This patch fixes an error when configuring the tarball, where configure complained it cannot find src/tests/Makefile.in.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e3cc569..1d69f34 100644
--- a/configure.in
+++ b/configure.in
@@ -308,6 +308,22 @@ AC_ARG_ENABLE(debug,
308AC_SUBST(DEBUG) 308AC_SUBST(DEBUG)
309CXXFLAGS="$CXXFLAGS $DEBUG" 309CXXFLAGS="$CXXFLAGS $DEBUG"
310 310
311dnl Check whether to build test programs
312AC_MSG_CHECKING([whether to build test programs])
313AC_ARG_ENABLE(test,
314 [ --enable-test build programs used in testing fluxbox ([default=no])],
315 if test x$enableval = "xyes"; then
316 AC_MSG_RESULT([yes])
317 TEST=yes
318 else
319 AC_MSG_RESULT([no])
320 TEST=no
321 fi,
322 AC_MSG_RESULT([no])
323 TEST=no
324)
325AM_CONDITIONAL(TEST, test x$TEST = xyes)
326
311dnl Check whether to include native language support (i18n) 327dnl Check whether to include native language support (i18n)
312AC_MSG_CHECKING([whether to include NLS support]) 328AC_MSG_CHECKING([whether to include NLS support])
313AC_ARG_ENABLE(nls, 329AC_ARG_ENABLE(nls,