aboutsummaryrefslogtreecommitdiff
path: root/nls/tr_TR/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nls/tr_TR/Makefile.am')
-rw-r--r--nls/tr_TR/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/nls/tr_TR/Makefile.am b/nls/tr_TR/Makefile.am
new file mode 100644
index 0000000..d6e34cb
--- /dev/null
+++ b/nls/tr_TR/Makefile.am
@@ -0,0 +1,34 @@
1# nls/tr_TR/Makefile.am for Blackbox-0.61.x - an X11 Window Manager
2#
3# -- Türkce tercüme dizini için bir yapim-dosya-tabanı
4# kabalak -- kabalak@gmx.net
5#
6
7NLSTEST = @NLS@
8CLEANFILES = blackbox.cat
9MAINTAINERCLEANFILES = Makefile.in Translation.m
10MFILES = BaseDisplay.m Basemenu.m Configmenu.m Icon.m Image.m Screen.m Slit.m Toolbar.m Window.m Windowmenu.m Workspace.m Workspacemenu.m blackbox.m common.m main.m bsetroot.m
11EXTRA_DIST=$(MFILES)
12
13all-local: blackbox.cat
14install-data-local: blackbox.cat
15 @if test x$(NLSTEST) = "x-DNLS"; then \
16 echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/tr_TR"; \
17 $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/tr_TR; \
18 $(INSTALL_DATA) blackbox.cat $(DESTDIR)$(pkgdatadir)/nls/tr_TR; \
19 fi
20uninstall-local:
21 @if test x$(NLSTEST) = "x-DNLS"; then \
22 rm -f $(DESTDIR)$(pkgdatadir)/nls/tr_TR/blackbox.cat; \
23 rmdir $(DESTDIR)$(pkgdatadir)/nls/tr_TR; \
24 fi
25
26Translation.m: $(MFILES)
27 @if test x$(NLSTEST) = "x-DNLS"; then \
28 awk -f ../convert.awk output=Translation.m $(MFILES); \
29 fi
30
31blackbox.cat: Translation.m
32 @if test x$(NLSTEST) = "x-DNLS"; then \
33 $(gencat_cmd) blackbox.cat Translation.m; \
34 fi