aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorPavel Labath <pavelo@centrum.sk>2011-08-19 15:01:07 (GMT)
committerPavel Labath <pavelo@centrum.sk>2011-11-01 10:04:03 (GMT)
commit8a3c7ff2ac1b615ed8f891814f5b3980b8327aae (patch)
treec0da38ddd391db2b2afd50c2bd569c306c677b4d /util/Makefile.am
parent18e8f7cd9906728864ecc3e25b2ab3e29070ec8a (diff)
downloadfluxbox_paul-8a3c7ff2ac1b615ed8f891814f5b3980b8327aae.zip
fluxbox_paul-8a3c7ff2ac1b615ed8f891814f5b3980b8327aae.tar.bz2
fluxbox-update_configs: automatically update menu file
To achieve this, I had to partially resurrect (and heavily modify) the old parsing code in MenuCreator.cc.
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index c2bbe74..c6dbd9d 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -6,7 +6,10 @@ bin_PROGRAMS= fbsetroot fluxbox-update_configs fluxbox-remote
6fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh 6fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh
7fbsetroot_LDADD=../src/FbRootWindow.o ../src/FbAtoms.o \ 7fbsetroot_LDADD=../src/FbRootWindow.o ../src/FbAtoms.o \
8 ../src/FbTk/libFbTk.a 8 ../src/FbTk/libFbTk.a
9fluxbox_update_configs_SOURCES= fluxbox-update_configs.cc update_keys-lua.cc 9fluxbox_update_configs_SOURCES= fluxbox-update_configs.cc \
10 update_keys-lua.cc \
11 FbMenuParser.cc FbMenuParser.hh \
12 MenuConvertor.cc MenuConvertor.hh
10fluxbox_update_configs_LDADD= ../src/defaults.o ../src/Resources.o \ 13fluxbox_update_configs_LDADD= ../src/defaults.o ../src/Resources.o \
11 ../src/FbTk/libFbTk.a ../libs/lua/src/liblua.a 14 ../src/FbTk/libFbTk.a ../libs/lua/src/liblua.a
12fluxbox_remote_SOURCES= fluxbox-remote.cc 15fluxbox_remote_SOURCES= fluxbox-remote.cc