aboutsummaryrefslogtreecommitdiff
path: root/nls/tr_TR/Makefile.am
diff options
context:
space:
mode:
authorrathnor <rathnor>2004-06-20 13:48:46 (GMT)
committerrathnor <rathnor>2004-06-20 13:48:46 (GMT)
commitc144177c5c43ce35cf8c7b0e888a597d6292b39a (patch)
tree23c3fc18b03aa61918bc7fb4c6f7e69dd795f5b1 /nls/tr_TR/Makefile.am
parentabc86f0028402a54ef74c378cf5b6805f01e0347 (diff)
downloadfluxbox_paul-c144177c5c43ce35cf8c7b0e888a597d6292b39a.zip
fluxbox_paul-c144177c5c43ce35cf8c7b0e888a597d6292b39a.tar.bz2
Conversion of old nls files to new string names...
Change to new style of working.
Diffstat (limited to 'nls/tr_TR/Makefile.am')
-rw-r--r--nls/tr_TR/Makefile.am38
1 files changed, 11 insertions, 27 deletions
diff --git a/nls/tr_TR/Makefile.am b/nls/tr_TR/Makefile.am
index b82bc9e..6f39142 100644
--- a/nls/tr_TR/Makefile.am
+++ b/nls/tr_TR/Makefile.am
@@ -1,38 +1,22 @@
1# nls/tr_TR/Makefile.am for Fluxbox - an X11 Window Manager 1# nls/tr_TR/Makefile.am for Fluxbox - www.fluxbox.org
2#
3# -- Türkce tercüme dizini için bir yapim-dosya-tabanı
4# kabalak -- kabalak@gmx.net
5#
6 2
7THE_LANG = tr_TR 3THE_LANG = tr_TR
8CODESET = ISO-8859-1
9 4
10NLSTEST = @NLS@ 5NLSTEST = @NLS@
11CLEANFILES = fluxbox.cat 6CLEANFILES = fluxbox.cat
12MAINTAINERCLEANFILES = Makefile.in Translation.m 7MAINTAINERCLEANFILES = Makefile.in
13MFILES = BaseDisplay.m Basemenu.m Configmenu.m Icon.m Image.m Screen.m Slit.m Toolbar.m Window.m Windowmenu.m Workspace.m Workspacemenu.m fluxbox.m common.m main.m bsetroot.m 8MFILES = Translation.m
14EXTRA_DIST = $(MFILES) 9EXTRA_DIST= $(MFILES)
15 10
16all-local: fluxbox.cat 11all-local: fluxbox.cat
17install-data-local: fluxbox.cat 12install-data-local: fluxbox.cat
18 @if test x$(NLSTEST) = "x-DNLS"; then \ 13 @if test x$(NLSTEST) = "x-DNLS"; then echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/$(THE_LA
19 echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)"; \ 14NG)"; $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); $(INSTALL_DATA) fluxbox.cat $(DESTDIR)$(pkgdatadir)/nls/$(THE_LA
20 $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \ 15NG); fi
21 $(INSTALL_DATA) fluxbox.cat $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
22 fi
23uninstall-local:
24 @if test x$(NLSTEST) = "x-DNLS"; then \
25 rm -f $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)/fluxbox.cat; \
26 rmdir $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
27 fi
28 16
29Translation.m: $(MFILES) 17uninstall-local:
30 @if test x$(NLSTEST) = "x-DNLS"; then \ 18 @if test x$(NLSTEST) = "x-DNLS"; then rm -f $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)/fluxbox.cat; rmdir $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); fi
31 rm -f Translation.m; \
32 awk -f ../convert.awk codeset=$(CODESET) codeset=$(CODESET) output=Translation.m $(MFILES); \
33 fi
34 19
35fluxbox.cat: Translation.m 20fluxbox.cat: Translation.m
36 @if test x$(NLSTEST) = "x-DNLS"; then \ 21 @if test x$(NLSTEST) = "x-DNLS"; then $(gencat_cmd) fluxbox.cat Translation.m; fi
37 LANG=$(THE_LANG) $(gencat_cmd) fluxbox.cat Translation.m; \ 22
38 fi