aboutsummaryrefslogtreecommitdiff
path: root/src/FbTk/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/FbTk/Makefile.am')
-rw-r--r--src/FbTk/Makefile.am76
1 files changed, 0 insertions, 76 deletions
diff --git a/src/FbTk/Makefile.am b/src/FbTk/Makefile.am
deleted file mode 100644
index 983f923..0000000
--- a/src/FbTk/Makefile.am
+++ /dev/null
@@ -1,76 +0,0 @@
1noinst_LIBRARIES = libFbTk.a
2
3AM_CPPFLAGS=-include $(top_builddir)/config.h
4
5if XFT
6xft_SOURCE = XftFontImp.hh XftFontImp.cc
7endif
8if MULTIBYTE
9xmb_SOURCE= XmbFontImp.hh XmbFontImp.cc
10endif
11if XPM
12xpm_SOURCE= ImageXPM.hh ImageXPM.cc
13endif
14if IMLIB2
15imlib2_SOURCE= ImageImlib2.hh ImageImlib2.cc
16endif
17
18libFbTk_a_CPPFLAGS = $(FREETYPE2_CFLAGS) $(FRIBIDI_CFLAGS) $(AM_CPPFLAGS)
19
20libFbTk_a_SOURCES = App.hh App.cc \
21 Color.cc Color.hh Command.hh \
22 ColorLUT.cc ColorLUT.hh \
23 Accessor.hh DefaultValue.hh \
24 FileUtil.hh FileUtil.cc \
25 EventHandler.hh EventManager.hh EventManager.cc \
26 FbWindow.hh FbWindow.cc Font.cc Font.hh FontImp.hh \
27 I18n.cc I18n.hh \
28 CommandParser.hh \
29 RadioMenuItem.hh \
30 ImageControl.hh ImageControl.cc \
31 LogicCommands.hh LogicCommands.cc \
32 MacroCommand.hh MacroCommand.cc \
33 Menu.hh Menu.cc MenuItem.hh MenuItem.cc \
34 BoolMenuItem.hh IntMenuItem.hh \
35 MultiButtonMenuItem.hh MultiButtonMenuItem.cc \
36 MenuTheme.hh MenuTheme.cc NotCopyable.hh \
37 BorderTheme.hh BorderTheme.cc TextTheme.hh TextTheme.cc \
38 RefCount.hh SimpleCommand.hh SignalHandler.cc SignalHandler.hh \
39 TextUtils.hh TextUtils.cc Orientation.hh \
40 Texture.cc Texture.hh TextureRender.hh TextureRender.cc \
41 Shape.hh Shape.cc \
42 Theme.hh Theme.cc ThemeItems.cc Timer.hh Timer.cc \
43 FbTime.cc FbTime.hh \
44 XFontImp.cc XFontImp.hh \
45 Button.hh Button.cc \
46 TextButton.hh TextButton.cc \
47 Container.hh Container.cc \
48 MultLayers.cc MultLayers.hh \
49 Layer.cc Layer.hh LayerItem.cc LayerItem.hh \
50 Resource.hh Resource.cc \
51 StringUtil.hh StringUtil.cc Parser.hh Parser.cc \
52 RegExp.hh RegExp.cc \
53 FbString.hh FbString.cc \
54 AutoReloadHelper.hh AutoReloadHelper.cc \
55 Transparent.hh Transparent.cc \
56 FbPixmap.hh FbPixmap.cc \
57 FbDrawable.hh FbDrawable.cc \
58 XrmDatabaseHelper.hh \
59 Image.hh Image.cc \
60 PixmapWithMask.hh \
61 Compose.hh CompareEqual.hh \
62 TextBox.hh TextBox.cc \
63 GContext.hh GContext.cc \
64 KeyUtil.hh KeyUtil.cc \
65 MenuSeparator.hh MenuSeparator.cc \
66 stringstream.hh \
67 TypeAhead.hh SearchResult.hh SearchResult.cc ITypeAheadable.hh \
68 Select2nd.hh STLUtil.hh \
69 CachedPixmap.hh CachedPixmap.cc \
70 Slot.hh Signal.hh MemFun.hh SelectArg.hh \
71 Util.hh \
72 RelCalcHelper.hh RelCalcHelper.cc \
73 ${xpm_SOURCE} \
74 ${xft_SOURCE} \
75 ${xmb_SOURCE} \
76 $(imlib2_SOURCE)