aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in17
1 files changed, 9 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index ff070bb..581bc2b 100644
--- a/configure.in
+++ b/configure.in
@@ -229,21 +229,22 @@ AM_PATH_XFT(yes,
229if test "x$XFT" = "xtrue" ; then 229if test "x$XFT" = "xtrue" ; then
230 AC_TRY_LINK([ 230 AC_TRY_LINK([
231 #include <X11/Xft/Xft.h> 231 #include <X11/Xft/Xft.h>
232 ], [ XftCloseFont(0, 0); return 0; ], 232 ], [ XftFontClose(0, 0); return 1; ],
233 AC_DEFINE(USE_XFT, 1, "antialias support"), 233 [
234 234
235 AC_DEFINE(USE_XFT, 1, "antialias support") 235 AC_DEFINE(USE_XFT, 1, "antialias support")
236 AC_MSG_CHECKING([Xft UTF-8 support]) 236 AC_MSG_CHECKING([Xft UTF-8 support])
237 AC_TRY_LINK([ 237 AC_TRY_LINK([
238 #include <X11/Xft/Xft.h> 238 #include <X11/Xft/Xft.h>
239 ], [ XftDrawStringUtf8(0, 0, 0, 0, 0, 0, 0); return 0; ], 239 ], [ XftDrawStringUtf8(0, 0, 0, 0, 0, 0, 0); return 0; ],
240 AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support") 240 AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support")
241 AC_MSG_RESULT(yes), 241 AC_MSG_RESULT(yes),
242 AC_MSG_RESULT(no) 242 AC_MSG_RESULT(no)
243 ),
244 AC_MSG_RESULT([Could not link with Xft. Install Xft if you want support for it.])
245 XFT=false
246 ) 243 )
244 ],
245 [ AC_MSG_RESULT([Could not link with Xft. Install Xft if you want support for it.])
246 XFT=false
247 ])
247fi 248fi
248 249
249AM_CONDITIONAL(XFT, test x$XFT = xtrue) 250AM_CONDITIONAL(XFT, test x$XFT = xtrue)