diff options
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 122 |
1 files changed, 41 insertions, 81 deletions
diff --git a/configure.in b/configure.in index 73662ae..8fa5a8e 100644 --- a/configure.in +++ b/configure.in | |||
@@ -18,6 +18,13 @@ AC_PROG_CXX | |||
18 | AC_PROG_INSTALL | 18 | AC_PROG_INSTALL |
19 | AC_PROG_RANLIB | 19 | AC_PROG_RANLIB |
20 | 20 | ||
21 | AC_C_CONST | ||
22 | AC_C_INLINE | ||
23 | |||
24 | AC_TYPE_PID_T | ||
25 | AC_TYPE_SIZE_T | ||
26 | |||
27 | |||
21 | AC_CHECK_PROGS(regex_cmd, sed) | 28 | AC_CHECK_PROGS(regex_cmd, sed) |
22 | if test x$regex_cmd = "x"; then | 29 | if test x$regex_cmd = "x"; then |
23 | AC_MSG_ERROR([error. sed is required to build the data files.]) | 30 | AC_MSG_ERROR([error. sed is required to build the data files.]) |
@@ -25,12 +32,15 @@ fi | |||
25 | 32 | ||
26 | dnl Check for system header files | 33 | dnl Check for system header files |
27 | AC_HEADER_STDC | 34 | AC_HEADER_STDC |
35 | AC_HEADER_STDBOOL | ||
28 | AC_CHECK_HEADERS(errno.h ctype.h dirent.h fcntl.h libgen.h \ | 36 | AC_CHECK_HEADERS(errno.h ctype.h dirent.h fcntl.h libgen.h \ |
29 | locale.h nl_types.h process.h signal.h stdarg.h \ | 37 | locale.h nl_types.h process.h signal.h stdarg.h \ |
30 | stdio.h time.h unistd.h \ | 38 | stdio.h time.h unistd.h \ |
31 | sys/param.h sys/select.h sys/signal.h sys/stat.h \ | 39 | sys/param.h sys/select.h sys/signal.h sys/stat.h \ |
32 | sys/time.h sys/types.h sys/wait.h \ | 40 | sys/time.h sys/types.h sys/wait.h \ |
33 | iconv.h) | 41 | langinfo.h iconv.h) |
42 | |||
43 | |||
34 | 44 | ||
35 | AC_CHECK_HEADERS(sstream, , | 45 | AC_CHECK_HEADERS(sstream, , |
36 | [ AC_CHECK_HEADERS(strstream,, | 46 | [ AC_CHECK_HEADERS(strstream,, |
@@ -40,11 +50,21 @@ AC_CHECK_HEADERS(sstream, , | |||
40 | 50 | ||
41 | AC_CHECK_HEADERS(cassert cctype cerrno cmath cstdarg cstdio cstdlib cstring ctime) | 51 | AC_CHECK_HEADERS(cassert cctype cerrno cmath cstdarg cstdio cstdlib cstring ctime) |
42 | 52 | ||
43 | AC_HEADER_TIME | ||
44 | 53 | ||
45 | dnl Check for existance of basename(), setlocale() and strftime() | 54 | dnl Check for existance of basename(), setlocale() and strftime() |
55 | AC_FUNC_CLOSEDIR_VOID | ||
56 | AC_FUNC_ERROR_AT_LINE | ||
57 | AC_FUNC_FORK | ||
58 | AC_FUNC_MALLOC | ||
59 | AC_FUNC_REALLOC | ||
60 | AC_FUNC_SELECT_ARGTYPES | ||
61 | AC_FUNC_STAT | ||
62 | |||
46 | AC_CHECK_FUNCS(basename, , AC_CHECK_LIB(gen, basename, LIBS="$LIBS -lgen")) | 63 | AC_CHECK_FUNCS(basename, , AC_CHECK_LIB(gen, basename, LIBS="$LIBS -lgen")) |
47 | AC_CHECK_FUNCS(getpid setlocale sigaction strcasestr snprintf vsnprintf catopen catgets catclose) | 64 | AC_CHECK_FUNCS(catclose catgets catopen getpid gettimeofday memset mkdir \ |
65 | nl_langinfo putenv regcomp select setenv setlocale sigaction snprintf \ | ||
66 | sqrt strcasecmp strcasestr strchr strstr strtol strtoul vsnprintf) | ||
67 | |||
48 | dnl The autoconf test for strftime is broken now (due to gcc 3.3 bug?): | 68 | dnl The autoconf test for strftime is broken now (due to gcc 3.3 bug?): |
49 | dnl Gcc 3.3 testprog = ``extern "C" char strftime;'', build with g++ test.cc | 69 | dnl Gcc 3.3 testprog = ``extern "C" char strftime;'', build with g++ test.cc |
50 | dnl breaks with: | 70 | dnl breaks with: |
@@ -69,6 +89,8 @@ size_t x = strftime(s, 5, "%a", localtime(&t)); | |||
69 | [AC_MSG_RESULT(no)]) | 89 | [AC_MSG_RESULT(no)]) |
70 | 90 | ||
71 | 91 | ||
92 | AC_STRUCT_TM | ||
93 | |||
72 | dnl --------------- | 94 | dnl --------------- |
73 | dnl CHECK FOR ICONV | 95 | dnl CHECK FOR ICONV |
74 | dnl --------------- | 96 | dnl --------------- |
@@ -608,21 +630,6 @@ AC_TYPE_SIGNAL | |||
608 | dnl Determine if maintainer portions of the Makefiles should be included. | 630 | dnl Determine if maintainer portions of the Makefiles should be included. |
609 | dnl AM_MAINTAINER_MODE | 631 | dnl AM_MAINTAINER_MODE |
610 | 632 | ||
611 | dnl Print results | ||
612 | AC_MSG_RESULT([]) | ||
613 | AC_MSG_RESULT([ $PACKAGE version $VERSION configured successfully.]) | ||
614 | AC_MSG_RESULT([]) | ||
615 | AC_MSG_RESULT([Using '$prefix' for installation.]) | ||
616 | AC_MSG_RESULT([Using '$DEFAULT_MENU' for location menu file.]) | ||
617 | AC_MSG_RESULT([Using '$DEFAULT_STYLE' by default style.]) | ||
618 | AC_MSG_RESULT([Using '$DEFAULT_KEYS' for location keys file.]) | ||
619 | AC_MSG_RESULT([Using '$DEFAULT_INIT' for location init file.]) | ||
620 | AC_MSG_RESULT([Using '$LOCALE_PATH' for nls files.]) | ||
621 | AC_MSG_RESULT([Using '$CXX' for C++ compiler.]) | ||
622 | AC_MSG_RESULT([Building with '$CXXFLAGS' for C++ compiler flags.]) | ||
623 | AC_MSG_RESULT([Building with '$LIBS' for linker flags.]) | ||
624 | AC_MSG_RESULT([]) | ||
625 | |||
626 | dnl Output files | 633 | dnl Output files |
627 | AM_CONFIG_HEADER(config.h) | 634 | AM_CONFIG_HEADER(config.h) |
628 | 635 | ||
@@ -693,66 +700,19 @@ nls/zh_CN/Makefile | |||
693 | nls/zh_TW/Makefile | 700 | nls/zh_TW/Makefile |
694 | ) | 701 | ) |
695 | 702 | ||
696 | dnl autoscan suggested these as of 2cac7ddf6fb0b3c937c4ea7b55b20960e362a360 | 703 | dnl Print results |
697 | dnl wanted by: src/ClockTool.cc:262 | 704 | AC_MSG_RESULT([]) |
698 | AC_CHECK_FUNCS([gettimeofday]) | 705 | AC_MSG_RESULT([ $PACKAGE version $VERSION configured successfully.]) |
699 | dnl wanted by: src/Ewmh.cc:770 | 706 | AC_MSG_RESULT([]) |
700 | AC_CHECK_FUNCS([memset]) | 707 | AC_MSG_RESULT([Using '$prefix' for installation.]) |
701 | dnl wanted by: src/fluxbox.cc:553 | 708 | AC_MSG_RESULT([Using '$DEFAULT_MENU' for location menu file.]) |
702 | AC_CHECK_FUNCS([mkdir]) | 709 | AC_MSG_RESULT([Using '$DEFAULT_STYLE' by default style.]) |
703 | dnl wanted by: src/FbTk/FbString.cc:80 | 710 | AC_MSG_RESULT([Using '$DEFAULT_KEYS' for location keys file.]) |
704 | AC_CHECK_FUNCS([nl_langinfo]) | 711 | AC_MSG_RESULT([Using '$DEFAULT_INIT' for location init file.]) |
705 | dnl wanted by: src/FbCommands.cc:172 | 712 | AC_MSG_RESULT([Using '$LOCALE_PATH' for nls files.]) |
706 | AC_CHECK_FUNCS([putenv]) | 713 | AC_MSG_RESULT([Using '$CXX' for C++ compiler.]) |
707 | dnl wanted by: src/FbTk/RegExp.cc:56 | 714 | AC_MSG_RESULT([Building with '$CXXFLAGS' for C++ compiler flags.]) |
708 | AC_CHECK_FUNCS([regcomp]) | 715 | AC_MSG_RESULT([Building with '$LIBS' for linker flags.]) |
709 | dnl wanted by: src/FbTk/Timer.cc:156 | 716 | AC_MSG_RESULT([]) |
710 | AC_CHECK_FUNCS([select]) | 717 | AC_MSG_RESULT([Now build $PACKAGE with 'make']) |
711 | dnl wanted by: src/FbCommands.cc:206 | 718 | AC_MSG_RESULT([]) |
712 | AC_CHECK_FUNCS([setenv]) | ||
713 | dnl wanted by: src/WorkspaceCmd.cc:403 | ||
714 | AC_CHECK_FUNCS([sqrt]) | ||
715 | dnl wanted by: src/ClientPattern.cc:104 | ||
716 | AC_CHECK_FUNCS([strcasecmp]) | ||
717 | dnl wanted by: src/FbTk/XmbFontImp.cc:101 | ||
718 | AC_CHECK_FUNCS([strchr]) | ||
719 | dnl wanted by: src/RootTheme.cc:187 | ||
720 | AC_CHECK_FUNCS([strstr]) | ||
721 | dnl wanted by: src/Window.cc:4165 | ||
722 | AC_CHECK_FUNCS([strtol]) | ||
723 | dnl wanted by: src/Keys.cc:422 | ||
724 | AC_CHECK_FUNCS([strtoul]) | ||
725 | dnl wanted by: src/FbTk/FbString.cc:43 | ||
726 | AC_CHECK_HEADERS([langinfo.h]) | ||
727 | dnl wanted by: src/AlphaMenu.cc:51 | ||
728 | AC_C_CONST | ||
729 | dnl wanted by: src/Window.cc:3259 | ||
730 | AC_C_INLINE | ||
731 | dnl wanted by: src/FbTk/FileUtil.cc:117 | ||
732 | AC_FUNC_CLOSEDIR_VOID | ||
733 | dnl wanted by: src/ClientPattern.cc:333 | ||
734 | AC_FUNC_ERROR_AT_LINE | ||
735 | dnl wanted by: src/FbCommands.cc:144 | ||
736 | AC_FUNC_FORK | ||
737 | dnl wanted by: src/FbTk/FbString.cc:150 | ||
738 | AC_FUNC_MALLOC | ||
739 | dnl wanted by: src/FbTk/FbString.cc:181 | ||
740 | AC_FUNC_REALLOC | ||
741 | dnl wanted by: src/FbTk/Timer.cc:156 | ||
742 | AC_FUNC_SELECT_ARGTYPES | ||
743 | dnl wanted by: src/Slit.cc:1149 | ||
744 | AC_FUNC_STAT | ||
745 | dnl wanted by: src/ClockTool.cc:273 | ||
746 | AC_FUNC_STRFTIME | ||
747 | dnl wanted by: src/FbTk/FileUtil.hh:34 | ||
748 | AC_HEADER_DIRENT | ||
749 | dnl wanted by: src/AlphaMenu.hh:49 | ||
750 | AC_HEADER_STDBOOL | ||
751 | dnl wanted by: src/Keys.cc:75 | ||
752 | AC_HEADER_SYS_WAIT | ||
753 | dnl wanted by: src/AlphaMenu.cc:37 | ||
754 | AC_STRUCT_TM | ||
755 | dnl wanted by: src/FbCommands.cc:144 | ||
756 | AC_TYPE_PID_T | ||
757 | dnl wanted by: src/ClientMenu.cc:128 | ||
758 | AC_TYPE_SIZE_T | ||