aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorfluxgen <fluxgen>2003-09-07 19:14:10 (GMT)
committerfluxgen <fluxgen>2003-09-07 19:14:10 (GMT)
commitf2c58a0348c4b3feb1b664ee51b7cd14f0632b28 (patch)
tree1978ef57f3dd549e4ec30c70463fc3766aac132f /util/Makefile.am
parent44f0695af5832e9e6b74c7df3b1fda93e7608f28 (diff)
downloadfluxbox-f2c58a0348c4b3feb1b664ee51b7cd14f0632b28.zip
fluxbox-f2c58a0348c4b3feb1b664ee51b7cd14f0632b28.tar.bz2
update
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am40
1 files changed, 28 insertions, 12 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index 63820c6..2637c1e 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -1,17 +1,33 @@
1# util/Makefile.am for Fluxbox 1# util/Makefile.am for Fluxbox
2SUBDIRS = fbrun 2SUBDIRS= fbrun
3INCLUDES=-I../src/FbTk/ 3INCLUDES= -I../src/FbTk/
4bin_SCRIPTS = fbsetbg fluxbox-generate_menu 4bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox
5bin_PROGRAMS = bsetroot 5bin_PROGRAMS= bsetroot
6bsetroot_SOURCES = bsetroot.cc bsetroot.hh 6bsetroot_SOURCES= bsetroot.cc bsetroot.hh
7bsetroot_LDADD = ../src/FbRootWindow.o ../src/I18n.o ../src/FbAtoms.o \ 7bsetroot_LDADD= ../src/FbRootWindow.o ../src/I18n.o \
8 ../src/FbTk/libFbTk.a 8 ../src/FbAtoms.o ../src/FbTk/libFbTk.a
9 9
10MAINTAINERCLEANFILES = Makefile.in 10MAINTAINERCLEANFILES= Makefile.in
11EXTRA_DIST=fbsetbg fluxbox-generate_menu 11EXTRA_DIST= fbsetbg fluxbox-generate_menu startfluxbox
12
13all-local: startfluxbox
12 14
13distclean-local: 15distclean-local:
14 rm -f *\~ Makefile.in 16 rm -f *\~ Makefile.in
17
18clean-local:
19 rm -f startfluxbox
20
21bsetroot.o: bsetroot.cc ../config.h bsetroot.hh ../src/FbRootWindow.hh ../src/FbAtoms.hh
15 22
16bsetroot.o: bsetroot.cc ../config.h bsetroot.hh ../src/FbRootWindow.hh ../src/FbAtoms.hh 23startfluxbox: startfluxbox.in
24 @regex_cmd@ -e "s,@pkgdatadir@,$(pkgdatadir),g" \
25 -e "s,@pkgbindir@,$(bindir),g" \
26 startfluxbox.in > startfluxbox
17 27
28../src/FbRootWindow.o:
29 cd ../src && make FbRootWindow.o
30../src/I18n.o:
31 cd ../src && make I18n.o
32../src/FbAtoms.o:
33 cd ../src && make FbAtoms.o