aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorSami Kerola <kerolasa@iki.fi>2013-02-13 21:33:09 (GMT)
committerSami Kerola <kerolasa@iki.fi>2013-05-26 09:38:10 (GMT)
commit9e5eddfc3d42afc7455cdccc4907ea57a98aeb47 (patch)
tree4888f208bbc8d7751ddf0f3126d0672b873a5249 /util/Makefile.am
parent22ddf8fd3650072c6243941f27617158e111b236 (diff)
downloadfluxbox-9e5eddfc3d42afc7455cdccc4907ea57a98aeb47.zip
fluxbox-9e5eddfc3d42afc7455cdccc4907ea57a98aeb47.tar.bz2
build-sys: use pkg-config to locate dependencies
This commit alters XRANDR (X Resize And Rotate) extension dependency, which is expected to have at least version 1.4. Earlier old versions of xrandr were supported, at least to some extent.
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index 1123f68..63fe66a 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -6,10 +6,21 @@ bin_PROGRAMS= fbsetroot fluxbox-update_configs fluxbox-remote
6fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh 6fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh
7fbsetroot_LDADD=../src/FbRootWindow.o ../src/FbAtoms.o \ 7fbsetroot_LDADD=../src/FbRootWindow.o ../src/FbAtoms.o \
8 ../src/FbTk/libFbTk.a 8 ../src/FbTk/libFbTk.a
9fbsetroot_LDFLAGS = \
10 $(FONTCONFIG_LIBS) \
11 $(FRIBIDI_LIBS) \
12 $(X11_LIBS) \
13 $(XFT_LIBS) \
14 $(XRENDER_LIBS)
15
9fluxbox_update_configs_SOURCES= fluxbox-update_configs.cc 16fluxbox_update_configs_SOURCES= fluxbox-update_configs.cc
10fluxbox_update_configs_LDADD= ../src/defaults.o ../src/Resources.o \ 17fluxbox_update_configs_LDADD= ../src/defaults.o ../src/Resources.o \
11 ../src/FbTk/libFbTk.a 18 ../src/FbTk/libFbTk.a
19fluxbox_update_configs_LDFLAGS = \
20 $(FRIBIDI_LIBS) \
21 $(X11_LIBS)
12fluxbox_remote_SOURCES= fluxbox-remote.cc 22fluxbox_remote_SOURCES= fluxbox-remote.cc
23fluxbox_remote_LDFLAGS = $(X11_LIBS)
13 24
14MAINTAINERCLEANFILES= Makefile.in 25MAINTAINERCLEANFILES= Makefile.in
15EXTRA_DIST= fbsetbg fluxbox-generate_menu.in \ 26EXTRA_DIST= fbsetbg fluxbox-generate_menu.in \