aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authormarkt <markt>2007-02-09 18:13:01 (GMT)
committermarkt <markt>2007-02-09 18:13:01 (GMT)
commit6fdda1a31d2417c23f5f222114d30ce6abec8b40 (patch)
tree929a0c0a5ffac232568011ef055934354f4367da /util/Makefile.am
parent93d8310c0c51fe1edcdfa5240f724ab6306ce92a (diff)
downloadfluxbox-6fdda1a31d2417c23f5f222114d30ce6abec8b40.zip
fluxbox-6fdda1a31d2417c23f5f222114d30ce6abec8b40.tar.bz2
added mouse bindings to the keys file
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index 53a61d7..263c456 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -2,10 +2,13 @@
2SUBDIRS= fbrun 2SUBDIRS= fbrun
3INCLUDES= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk 3INCLUDES= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk
4bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox 4bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox
5bin_PROGRAMS= fbsetroot 5bin_PROGRAMS= fbsetroot fluxbox-update_configs
6fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh 6fbsetroot_SOURCES= fbsetroot.cc fbsetroot.hh
7fbsetroot_LDADD=../src/FbRootWindow.o ../src/FbAtoms.o \ 7fbsetroot_LDADD=../src/FbRootWindow.o ../src/FbAtoms.o \
8 ../src/FbTk/libFbTk.a 8 ../src/FbTk/libFbTk.a
9fluxbox_update_configs_SOURCES= fluxbox-update_configs.cc
10fluxbox_update_configs_LDADD= ../src/defaults.o ../src/Resources.o \
11 ../src/FbTk/libFbTk.a
9 12
10MAINTAINERCLEANFILES= Makefile.in 13MAINTAINERCLEANFILES= Makefile.in
11EXTRA_DIST= fbsetbg fluxbox-generate_menu.in \ 14EXTRA_DIST= fbsetbg fluxbox-generate_menu.in \
@@ -22,6 +25,9 @@ clean-local:
22fbsetroot.o: fbsetroot.cc ../config.h $(srcdir)/fbsetroot.hh \ 25fbsetroot.o: fbsetroot.cc ../config.h $(srcdir)/fbsetroot.hh \
23 $(top_srcdir)/src/FbRootWindow.hh $(top_srcdir)/src/FbAtoms.hh 26 $(top_srcdir)/src/FbRootWindow.hh $(top_srcdir)/src/FbAtoms.hh
24 27
28fluxbox-update_configs.o: fluxbox-update_configs.cc ../config.h \
29 $(top_srcdir)/src/defaults.hh
30
25startfluxbox: startfluxbox.in 31startfluxbox: startfluxbox.in
26 @regex_cmd@ -e "s,@pkgdatadir@,$(pkgdatadir),g" \ 32 @regex_cmd@ -e "s,@pkgdatadir@,$(pkgdatadir),g" \
27 -e "s,@pkgbindir@,$(bindir),g" \ 33 -e "s,@pkgbindir@,$(bindir),g" \
@@ -40,3 +46,7 @@ fluxbox-generate_menu: fluxbox-generate_menu.in
40 cd ../src && ${MAKE} FbRootWindow.o 46 cd ../src && ${MAKE} FbRootWindow.o
41../src/FbAtoms.o: 47../src/FbAtoms.o:
42 cd ../src && ${MAKE} FbAtoms.o 48 cd ../src && ${MAKE} FbAtoms.o
49../src/defaults.o:
50 cd ../src && ${MAKE} defaults.o
51../src/Resources.o:
52 cd ../src && ${MAKE} Resources.o