aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authormathias <mathias>2005-08-23 06:39:48 (GMT)
committermathias <mathias>2005-08-23 06:39:48 (GMT)
commitda8d245704832c6473eb8b9a7e4d59b16d96daad (patch)
tree85b0297b94e6b2f11d76264d9ca8a9f637e5b01b /src/Makefile.am
parent8c3cfbef7d3054a90258d59bac3385f98f96a12b (diff)
downloadfluxbox-da8d245704832c6473eb8b9a7e4d59b16d96daad.zip
fluxbox-da8d245704832c6473eb8b9a7e4d59b16d96daad.tar.bz2
--disable-regexp switches from <regexp.h> to <string> in
Regexp.cc .. but it still needs to be compiled. hence the little fix in src/Makefile.am
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 9e15d8b..3ccf687 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -65,11 +65,9 @@ if GNOME
65gnome_SOURCE= Gnome.hh Gnome.cc 65gnome_SOURCE= Gnome.hh Gnome.cc
66endif 66endif
67if REMEMBER_SRC 67if REMEMBER_SRC
68REMEMBER_SOURCE= Remember.hh Remember.cc
69# For now we only want regexp if we have remember 68# For now we only want regexp if we have remember
70if REGEXP_SRC 69REMEMBER_SOURCE= Remember.hh Remember.cc \
71REGEXP_SOURCE = RegExp.hh RegExp.cc ClientPattern.hh ClientPattern.cc 70 RegExp.hh RegExp.cc ClientPattern.hh ClientPattern.cc
72endif
73endif 71endif
74if TOOLBAR_SRC 72if TOOLBAR_SRC
75TOOLBAR_SOURCE = Toolbar.hh Toolbar.cc \ 73TOOLBAR_SOURCE = Toolbar.hh Toolbar.cc \
@@ -130,7 +128,7 @@ fluxbox_SOURCES = AtomHandler.hh ArrowButton.hh ArrowButton.cc \
130 Resources.cc \ 128 Resources.cc \
131 WindowCmd.hh WindowCmd.cc \ 129 WindowCmd.hh WindowCmd.cc \
132 ${newwmspec_SOURCE} ${gnome_SOURCE} \ 130 ${newwmspec_SOURCE} ${gnome_SOURCE} \
133 ${REMEMBER_SOURCE} ${REGEXP_SOURCE} ${TOOLBAR_SOURCE} 131 ${REMEMBER_SOURCE} ${TOOLBAR_SOURCE}
134 132
135 133
136LDADD=FbTk/libFbTk.a defaults.$(OBJEXT) 134LDADD=FbTk/libFbTk.a defaults.$(OBJEXT)