aboutsummaryrefslogtreecommitdiff
path: root/src/FbTk/Makefile.am
diff options
context:
space:
mode:
authormathias <mathias>2004-12-21 23:42:09 (GMT)
committermathias <mathias>2004-12-21 23:42:09 (GMT)
commitbc7c988561f79edb03b2ece80bb4ba0c8c73fc2e (patch)
treea48f394504f8b44cdab668ef69daf054c178500c /src/FbTk/Makefile.am
parent7e41a1494a65ecdb05c7a34c274693cbd950647f (diff)
downloadfluxbox-bc7c988561f79edb03b2ece80bb4ba0c8c73fc2e.zip
fluxbox-bc7c988561f79edb03b2ece80bb4ba0c8c73fc2e.tar.bz2
adds imlib2-support to fluxbox: allows us to load several imageformats
besides xpm. to get imlib2 support in fluxbox one has to ./configure --enable-imblib2 default is disabled. a fluxbox-binary that supports imlib2 will have IMLIB2 in "fluxbox -info"-output explanation to the changed files: * xft.m4 -> acinclude.m4 + added ac_path_generic.m4 (from http://ac-archive.sourceforge.net/Miscellaneous/ac_path_generic.html) * configure.in, Makefile.am, src/FbTk/Makefile.am changed to handle imlib2-support * Font.cc/hh Image.cc/hh App.cc fluxbox.cc consistent way of init for global stuff for fonts and imagehandlers. * rest of changes just add the imlib2-code, pretty straightforward
Diffstat (limited to 'src/FbTk/Makefile.am')
-rw-r--r--src/FbTk/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/src/FbTk/Makefile.am b/src/FbTk/Makefile.am
index be9b3ef..47ed58f 100644
--- a/src/FbTk/Makefile.am
+++ b/src/FbTk/Makefile.am
@@ -11,6 +11,9 @@ endif
11if XPM 11if XPM
12xpm_SOURCE= ImageXPM.hh ImageXPM.cc 12xpm_SOURCE= ImageXPM.hh ImageXPM.cc
13endif 13endif
14if IMLIB2
15imlib2_SOURCE= ImageImlib2.hh ImageImlib2.cc
16endif
14 17
15libFbTk_a_SOURCES = App.hh App.cc Color.cc Color.hh Command.hh \ 18libFbTk_a_SOURCES = App.hh App.cc Color.cc Color.hh Command.hh \
16 FileUtil.hh FileUtil.cc \ 19 FileUtil.hh FileUtil.cc \
@@ -48,4 +51,5 @@ libFbTk_a_SOURCES = App.hh App.cc Color.cc Color.hh Command.hh \
48 MenuIcon.hh MenuIcon.cc \ 51 MenuIcon.hh MenuIcon.cc \
49 ${xpm_SOURCE} \ 52 ${xpm_SOURCE} \
50 ${xft_SOURCE} \ 53 ${xft_SOURCE} \
51 ${xmb_SOURCE} 54 ${xmb_SOURCE} \
55 ${imlib2_SOURCE}