aboutsummaryrefslogtreecommitdiff
path: root/src/FbTk/Makefile.am
diff options
context:
space:
mode:
authorHenrik Kinnunen <fluxgen@fluxbox.org>2008-04-27 19:22:18 (GMT)
committerHenrik Kinnunen <fluxgen@fluxbox.org>2008-04-27 19:22:18 (GMT)
commit80b10f7772b91f1f4a61eace4e5235a79060e1f0 (patch)
tree27057e59c41188e7c2f724614233265fed03c9b3 /src/FbTk/Makefile.am
parent40e17b4d0ef1b9503f21509e697dd4dcb24d2bbf (diff)
downloadfluxbox-80b10f7772b91f1f4a61eace4e5235a79060e1f0.zip
fluxbox-80b10f7772b91f1f4a61eace4e5235a79060e1f0.tar.bz2
Added SimpleObserver class.
This class works in the same way as the SimpleCommand class. Use it with the makeObserver function. It calls the receiver's member function when the subject sends a signal.
Diffstat (limited to 'src/FbTk/Makefile.am')
-rw-r--r--src/FbTk/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/FbTk/Makefile.am b/src/FbTk/Makefile.am
index 6fa874a..fcf0304 100644
--- a/src/FbTk/Makefile.am
+++ b/src/FbTk/Makefile.am
@@ -44,7 +44,7 @@ libFbTk_a_SOURCES = App.hh App.cc Color.cc Color.hh Command.hh \
44 StringUtil.hh StringUtil.cc Parser.hh Parser.cc \ 44 StringUtil.hh StringUtil.cc Parser.hh Parser.cc \
45 RegExp.hh RegExp.cc \ 45 RegExp.hh RegExp.cc \
46 FbString.hh FbString.cc \ 46 FbString.hh FbString.cc \
47 Subject.hh Subject.cc Observer.hh Observer.cc \ 47 Subject.hh Subject.cc Observer.hh Observer.cc SimpleObserver.hh \
48 Transparent.hh Transparent.cc \ 48 Transparent.hh Transparent.cc \
49 FbPixmap.hh FbPixmap.cc \ 49 FbPixmap.hh FbPixmap.cc \
50 FbDrawable.hh FbDrawable.cc \ 50 FbDrawable.hh FbDrawable.cc \