aboutsummaryrefslogtreecommitdiff
path: root/nls/pl_PL/Makefile.am
diff options
context:
space:
mode:
authorrathnor <rathnor>2004-06-20 13:48:46 (GMT)
committerrathnor <rathnor>2004-06-20 13:48:46 (GMT)
commitc144177c5c43ce35cf8c7b0e888a597d6292b39a (patch)
tree23c3fc18b03aa61918bc7fb4c6f7e69dd795f5b1 /nls/pl_PL/Makefile.am
parentabc86f0028402a54ef74c378cf5b6805f01e0347 (diff)
downloadfluxbox-c144177c5c43ce35cf8c7b0e888a597d6292b39a.zip
fluxbox-c144177c5c43ce35cf8c7b0e888a597d6292b39a.tar.bz2
Conversion of old nls files to new string names...
Change to new style of working.
Diffstat (limited to 'nls/pl_PL/Makefile.am')
-rw-r--r--nls/pl_PL/Makefile.am36
1 files changed, 9 insertions, 27 deletions
diff --git a/nls/pl_PL/Makefile.am b/nls/pl_PL/Makefile.am
index 52a2d6e..74191fe 100644
--- a/nls/pl_PL/Makefile.am
+++ b/nls/pl_PL/Makefile.am
@@ -1,40 +1,22 @@
1# nls/de_DE/Makefile.am for Fluxbox - fluxbox.sf.net 1# nls/pl_PL/Makefile.am for Fluxbox - www.fluxbox.org
2 2
3THE_LANG = pl_PL 3THE_LANG = pl_PL
4CODESET = ISO-8859-1
5 4
6NLSTEST = @NLS@ 5NLSTEST = @NLS@
7CLEANFILES = fluxbox.cat 6CLEANFILES = fluxbox.cat
8MAINTAINERCLEANFILES = Makefile.in Translation.m 7MAINTAINERCLEANFILES = Makefile.in
9MFILES = BaseDisplay.m Basemenu.m Configmenu.m Icon.m Image.m Screen.m Slit.m Toolbar.m Window.m Windowmenu.m Workspace.m Workspacemenu.m fluxbox.m common.m main.m bsetroot.m 8MFILES = Translation.m
10EXTRA_DIST= $(MFILES) 9EXTRA_DIST= $(MFILES)
11 10
12all-local: fluxbox.cat 11all-local: fluxbox.cat
13
14install-data-local: fluxbox.cat 12install-data-local: fluxbox.cat
15 @if test x$(NLSTEST) = "x-DNLS"; then \ 13 @if test x$(NLSTEST) = "x-DNLS"; then echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/$(THE_LA
16 echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)"; \ 14NG)"; $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); $(INSTALL_DATA) fluxbox.cat $(DESTDIR)$(pkgdatadir)/nls/$(THE_LA
17 $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \ 15NG); fi
18 $(INSTALL_DATA) fluxbox.cat $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
19 fi
20 16
21uninstall-local: 17uninstall-local:
22 @if test x$(NLSTEST) = "x-DNLS"; then \ 18 @if test x$(NLSTEST) = "x-DNLS"; then rm -f $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)/fluxbox.cat; rmdir $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); fi
23 rm -f $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG)/fluxbox.cat; \
24 rmdir $(DESTDIR)$(pkgdatadir)/nls/$(THE_LANG); \
25 fi
26
27# note... when adding new catalogs... you do not need the
28# header=../fluxbox-nls.hh which is passed to awk... we
29# only need to generate it once.
30
31Translation.m: $(MFILES)
32 @if test x$(NLSTEST) = "x-DNLS"; then \
33 rm -f Translation.m; \
34 awk -f ../convert.awk codeset=$(CODESET) output=Translation.m $(MFILES); \
35 fi
36 19
37fluxbox.cat: Translation.m 20fluxbox.cat: Translation.m
38 @if test x$(NLSTEST) = "x-DNLS"; then \ 21 @if test x$(NLSTEST) = "x-DNLS"; then $(gencat_cmd) fluxbox.cat Translation.m; fi
39 $(gencat_cmd) fluxbox.cat Translation.m; \ 22
40 fi