aboutsummaryrefslogtreecommitdiff
path: root/nls/es_ES/Makefile.am
diff options
context:
space:
mode:
authorsimonb <simonb>2006-05-20 15:08:14 (GMT)
committersimonb <simonb>2006-05-20 15:08:14 (GMT)
commit0861f3a9073ccd016302af26ff992fa19331a02d (patch)
treef1a2276449a5fc9b27f2d1afa5ffff4410141345 /nls/es_ES/Makefile.am
parent5ddabb0f390f69db793b5a6e40be9f94b8f83136 (diff)
downloadfluxbox-0861f3a9073ccd016302af26ff992fa19331a02d.zip
fluxbox-0861f3a9073ccd016302af26ff992fa19331a02d.tar.bz2
improve native language handling, move messages and menu labels to
FbTk::FbString
Diffstat (limited to 'nls/es_ES/Makefile.am')
-rw-r--r--nls/es_ES/Makefile.am42
1 files changed, 29 insertions, 13 deletions
diff --git a/nls/es_ES/Makefile.am b/nls/es_ES/Makefile.am
index d71114f..9fcb9f0 100644
--- a/nls/es_ES/Makefile.am
+++ b/nls/es_ES/Makefile.am
@@ -1,30 +1,46 @@
1# nls/es_ES/Makefile.am for Fluxbox - www.fluxbox.org 1# nls/es_ES/Makefile.am for Fluxbox - www.fluxbox.org
2 2
3THE_LANG = es_ES 3THE_LANG = es_ES
4SRC_CODESET = ISO-8859-15
5DEST_CODESETS = ISO-8859-15 UTF-8
4 6
5LOCALE_PATH = @LOCALE_PATH@ 7LOCALE_PATH = @LOCALE_PATH@
6NLSTEST = @NLS@ 8NLSTEST = @NLS@
7CLEANFILES = fluxbox.cat
8MAINTAINERCLEANFILES = Makefile.in
9MFILES = Translation.m 9MFILES = Translation.m
10EXTRA_DIST= $(MFILES) 10GENERATED_MFILES = $(patsubst %,generated-%.m,$(DEST_CODESETS))
11MAINTAINERCLEANFILES = Makefile.in $(GENERATED_MFILES)
12CATFILES = $(patsubst %,fluxbox-%.cat,$(DEST_CODESETS))
11 13
12all-local: fluxbox.cat 14# We distribute the generated files so that users don't need iconv
13install-data-local: fluxbox.cat 15EXTRA_DIST= $(MFILES) $(GENERATED_MFILES)
16CLEANFILES = $(CATFILES)
17
18all-local: $(CATFILES)
19install-data-local: $(CATFILES)
14 @if test x$(NLSTEST) = "x-DNLS"; then \ 20 @if test x$(NLSTEST) = "x-DNLS"; then \
15 echo "Installing catalog in $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG)"; \ 21 for codeset in $(DEST_CODESETS); do \
16 $(mkinstalldirs) $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG); \ 22 echo "Installing catalog in $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}"; \
17 $(INSTALL_DATA) fluxbox.cat $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG); \ 23 $(mkinstalldirs) $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}; \
24 $(INSTALL_DATA) fluxbox-$${codeset}.cat $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}/fluxbox.cat; \
25 done; \
18 fi 26 fi
19 27
28# not part of the normal build process
29translations: $(GENERATED_MFILES)
30
31generated-%.m: Translation.m
32 iconv -f $(SRC_CODESET) -t $* Translation.m | sed s/$(SRC_CODESET)/$*/ > $@
33
20uninstall-local: 34uninstall-local:
21 @if test x$(NLSTEST) = "x-DNLS"; then \ 35 @if test x$(NLSTEST) = "x-DNLS"; then \
22 rm -f $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG)/fluxbox.cat; \ 36 for codeset in $(DEST_CODESETS); do \
23 rmdir $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG); \ 37 rm -f $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}/fluxbox.cat; \
38 rmdir $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}; \
39 done; \
24 fi 40 fi
25 41
26fluxbox.cat: Translation.m 42fluxbox-%.cat: generated-%.m Translation.m
27 @if test x$(NLSTEST) = "x-DNLS"; then \ 43 @if test x$(NLSTEST) = "x-DNLS"; then \
28 $(gencat_cmd) fluxbox.cat Translation.m; \ 44 echo "Creating catfile for $*"; \
45 $(gencat_cmd) fluxbox-$*.cat generated-$*.m; \
29 fi 46 fi
30