aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorrathnor <rathnor>2003-06-12 15:12:19 (GMT)
committerrathnor <rathnor>2003-06-12 15:12:19 (GMT)
commite139cbb0283f7480fc26c58dc3f8a48e69011eab (patch)
tree2058a848943cb008dfe17270ad49853747212481 /configure.in
parent94f1c164161e8faaf064d8b7cdfe36c9ca978055 (diff)
downloadfluxbox-e139cbb0283f7480fc26c58dc3f8a48e69011eab.zip
fluxbox-e139cbb0283f7480fc26c58dc3f8a48e69011eab.tar.bz2
add regular expression support in remember capabilities
see ChangeLog for details
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in29
1 files changed, 26 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index a301393..a521abd 100644
--- a/configure.in
+++ b/configure.in
@@ -119,6 +119,32 @@ AC_ARG_ENABLE(
119) 119)
120AM_CONDITIONAL(REMEMBER_SRC, test x$REMEMBER_SRC = xtrue) 120AM_CONDITIONAL(REMEMBER_SRC, test x$REMEMBER_SRC = xtrue)
121 121
122AC_MSG_CHECKING([whether to have (POSIX) regular expression support])
123AC_ARG_ENABLE(
124 regexp,
125[ --enable-regexp regular expression support [default=yes]],
126 if test x$enableval = "xyes"; then
127 AC_EGREP_HEADER([regex_t],regex.h,
128 AC_DEFINE(USE_REGEXP, 1, "Regular Expression support")
129 AC_MSG_RESULT([yes])
130 REGEXP_SRC=true,
131 AC_MSG_RESULT([no])
132 REGEXP_SRC=false
133 )
134 else
135 AC_MSG_RESULT([no])
136 REGEXP_SRC=false
137 fi,
138 AC_EGREP_HEADER([regex_t],regex.h,
139 AC_DEFINE(USE_REGEXP, 1, "Regular Expression support")
140 AC_MSG_RESULT([yes])
141 REGEXP_SRC=true,
142 AC_MSG_RESULT([no])
143 REGEXP_SRC=false
144 )
145)
146AM_CONDITIONAL(REGEXP_SRC, test x$REGEXP_SRC = xtrue)
147
122AC_MSG_CHECKING([whether to include the new WM Spec]) 148AC_MSG_CHECKING([whether to include the new WM Spec])
123AC_ARG_ENABLE( 149AC_ARG_ENABLE(
124 newwmspec, 150 newwmspec,
@@ -307,9 +333,6 @@ AC_ARG_ENABLE(
307) 333)
308 334
309 335
310
311
312
313AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) 336AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support])
314AC_ARG_ENABLE( 337AC_ARG_ENABLE(
315 xmb, 338 xmb,