aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfluxgen <fluxgen>2004-08-31 20:24:23 (GMT)
committerfluxgen <fluxgen>2004-08-31 20:24:23 (GMT)
commitc37b8ec735c0f9f4782e354fec1be2f8ab053509 (patch)
tree013a6d1ce54ce447695ab358425db86b0b21299b /configure.in
parentd7a73c6f31c5e7e9c59e3f5a95a130249bd528ad (diff)
downloadfluxbox-c37b8ec735c0f9f4782e354fec1be2f8ab053509.zip
fluxbox-c37b8ec735c0f9f4782e354fec1be2f8ab053509.tar.bz2
fixed check for iconv, rearranged some stuff
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 23 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 79209f5..3bb27b2 100644
--- a/configure.in
+++ b/configure.in
@@ -63,6 +63,20 @@ size_t x = strftime(s, 5, "%a", localtime(&t));
63], 63],
64[AC_MSG_RESULT(no)]) 64[AC_MSG_RESULT(no)])
65 65
66AC_MSG_CHECKING([iconv])
67AC_TRY_COMPILE(
68[#include <iconv.h>],
69[iconv_t cd = iconv_open("", "")],
70HAVE_ICONV=yes,
71HAVE_ICONV=no)
72
73if test x"$HAVE_ICONV" = x"yes"; then
74 AC_DEFINE(HAVE_ICONV, 1, "iconv")
75 AC_MSG_RESULT([yes])
76else
77 AC_MSG_RESULT([no])
78fi
79
66AC_CHECK_LIB(nsl, t_open, LIBS="$LIBS -lnsl") 80AC_CHECK_LIB(nsl, t_open, LIBS="$LIBS -lnsl")
67AC_CHECK_LIB(socket, socket, LIBS="$LIBS -lsocket") 81AC_CHECK_LIB(socket, socket, LIBS="$LIBS -lsocket")
68 82
@@ -88,6 +102,13 @@ AC_CHECK_LIB(X11, XOpenDisplay,
88 102
89LIBS="$LIBS $X_EXTRA_LIBS" 103LIBS="$LIBS $X_EXTRA_LIBS"
90 104
105AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4")
106
107AC_CHECK_PROGS(gencat_cmd, gencat)
108if test x$gencat_cmd = "x"; then
109 NLS=""
110fi
111
91Xext_lib="" 112Xext_lib=""
92 113
93dnl Check for XShape extension support and proper library files. 114dnl Check for XShape extension support and proper library files.
@@ -257,12 +278,9 @@ AC_ARG_ENABLE(nls,
257) 278)
258AC_SUBST(NLS) 279AC_SUBST(NLS)
259 280
260AC_CHECK_LIB(xpg4, setlocale, LIBS="$LIBS -lxpg4")
261 281
262AC_CHECK_PROGS(gencat_cmd, gencat) 282
263if test x$gencat_cmd = "x"; then 283
264 NLS=""
265fi
266 284
267 285
268dnl Check for new timed pixmap cache 286dnl Check for new timed pixmap cache