aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormathias <mathias>2004-12-21 23:42:09 (GMT)
committermathias <mathias>2004-12-21 23:42:09 (GMT)
commitbc7c988561f79edb03b2ece80bb4ba0c8c73fc2e (patch)
treea48f394504f8b44cdab668ef69daf054c178500c /configure.in
parent7e41a1494a65ecdb05c7a34c274693cbd950647f (diff)
downloadfluxbox-bc7c988561f79edb03b2ece80bb4ba0c8c73fc2e.zip
fluxbox-bc7c988561f79edb03b2ece80bb4ba0c8c73fc2e.tar.bz2
adds imlib2-support to fluxbox: allows us to load several imageformats
besides xpm. to get imlib2 support in fluxbox one has to ./configure --enable-imblib2 default is disabled. a fluxbox-binary that supports imlib2 will have IMLIB2 in "fluxbox -info"-output explanation to the changed files: * xft.m4 -> acinclude.m4 + added ac_path_generic.m4 (from http://ac-archive.sourceforge.net/Miscellaneous/ac_path_generic.html) * configure.in, Makefile.am, src/FbTk/Makefile.am changed to handle imlib2-support * Font.cc/hh Image.cc/hh App.cc fluxbox.cc consistent way of init for global stuff for fonts and imagehandlers. * rest of changes just add the imlib2-code, pretty straightforward
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in26
1 files changed, 26 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index d03429e..5fd74a9 100644
--- a/configure.in
+++ b/configure.in
@@ -426,6 +426,32 @@ AC_ARG_ENABLE(
426 426
427AM_CONDITIONAL(XPM, test x$XPM = xtrue) 427AM_CONDITIONAL(XPM, test x$XPM = xtrue)
428 428
429IMLIB2=false
430AC_MSG_CHECKING([whether to have Imlib2 (pixmap themes) support])
431AC_ARG_ENABLE(imlib2,
432[ --enable-imlib2 Imlib2 (pixmap themes) support [default=no]])
433
434if test "x$enableval" = "xyes"; then
435 AC_MSG_RESULT([yes])
436 AC_PATH_GENERIC(imlib2, 1.0.0,
437 [
438 IMLIB2=true
439 AC_DEFINE(HAVE_IMLIB2, [], [Imlib2 support])
440 IMLIB2_LIBS=`imlib2-config --libs`
441 IMLIB2_CFLAGS=`imlib2-config --cflags`
442 LIBS="$LIBS $IMLIB2_LIBS"
443 CXXFLAGS="$CXXFLAGS $IMLIB2_CFLAGS"
444 ],
445 [
446 AC_MSG_RESULT(no)
447 ])
448else
449 AC_MSG_RESULT([no])
450fi
451
452AM_CONDITIONAL(IMLIB2, test x$IMLIB2 = xtrue)
453
454
429AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) 455AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support])
430AC_ARG_ENABLE( 456AC_ARG_ENABLE(
431 xmb, 457 xmb,