aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfluxgen <fluxgen>2003-08-22 22:54:50 (GMT)
committerfluxgen <fluxgen>2003-08-22 22:54:50 (GMT)
commit89a3b058d6d8f7ede6d3bb516f88c93d48c1bea5 (patch)
treef63fc228de3e251dc6211bb80cc245799dff4024 /configure.in
parent34fb292c06c260815eb05718c56b2d854ee77ca8 (diff)
downloadfluxbox-89a3b058d6d8f7ede6d3bb516f88c93d48c1bea5.zip
fluxbox-89a3b058d6d8f7ede6d3bb516f88c93d48c1bea5.tar.bz2
update
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 680881e..781f9ad 100644
--- a/configure.in
+++ b/configure.in
@@ -1,7 +1,7 @@
1dnl Initialize autoconf and automake 1dnl Initialize autoconf and automake
2AC_INIT(src/main.cc) 2AC_INIT(src/main.cc)
3AC_PREREQ(2.52) 3AC_PREREQ(2.52)
4AM_INIT_AUTOMAKE(fluxbox,0.9.5, no-define) 4AM_INIT_AUTOMAKE(fluxbox,0.9.5pre1, no-define)
5 5
6dnl Determine default prefix 6dnl Determine default prefix
7test x$prefix = "xNONE" && prefix="$ac_default_prefix" 7test x$prefix = "xNONE" && prefix="$ac_default_prefix"
@@ -354,6 +354,7 @@ AC_ARG_ENABLE(
354 LIBS="$LIBS -lXrender") 354 LIBS="$LIBS -lXrender")
355) 355)
356 356
357XPM=false
357AC_MSG_CHECKING([whether to have Xpm (pixmap themes) support]) 358AC_MSG_CHECKING([whether to have Xpm (pixmap themes) support])
358AC_ARG_ENABLE( 359AC_ARG_ENABLE(
359 xpm, 360 xpm,
@@ -362,6 +363,7 @@ AC_ARG_ENABLE(
362 AC_MSG_RESULT([yes]) 363 AC_MSG_RESULT([yes])
363 AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, 364 AC_CHECK_LIB(Xpm, XpmReadFileToPixmap,
364 AC_DEFINE(HAVE_XPM, 1, "Xpm support") 365 AC_DEFINE(HAVE_XPM, 1, "Xpm support")
366 XPM=true
365 LIBS="$LIBS -lXpm") 367 LIBS="$LIBS -lXpm")
366 else 368 else
367 AC_MSG_RESULT([no]) 369 AC_MSG_RESULT([no])
@@ -369,9 +371,11 @@ AC_ARG_ENABLE(
369 AC_MSG_RESULT([yes]) 371 AC_MSG_RESULT([yes])
370 AC_CHECK_LIB(Xpm, XpmReadFileToPixmap, 372 AC_CHECK_LIB(Xpm, XpmReadFileToPixmap,
371 AC_DEFINE(HAVE_XPM, 1, "Xpm support") 373 AC_DEFINE(HAVE_XPM, 1, "Xpm support")
374 XPM=true
372 LIBS="$LIBS -lXpm") 375 LIBS="$LIBS -lXpm")
373) 376)
374 377
378AM_CONDITIONAL(XPM, test x$XPM = xtrue)
375 379
376AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) 380AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support])
377AC_ARG_ENABLE( 381AC_ARG_ENABLE(