aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authormathias <mathias>2005-02-01 19:18:28 (GMT)
committermathias <mathias>2005-02-01 19:18:28 (GMT)
commit7e110482499a8b7834f0f91b11df44b4826a6717 (patch)
tree6877e48f9dc1a7211b4657634112422b48d52f4d /configure.in
parentaf526573b8b0359ae9c8141c3c222ea6133b30c6 (diff)
downloadfluxbox-7e110482499a8b7834f0f91b11df44b4826a6717.zip
fluxbox-7e110482499a8b7834f0f91b11df44b4826a6717.tar.bz2
imlib2 wasnt default-off as it seems, this should fix it
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in25
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.in b/configure.in
index 40acb6b..f01c9f3 100644
--- a/configure.in
+++ b/configure.in
@@ -426,32 +426,33 @@ AC_ARG_ENABLE(
426 426
427AM_CONDITIONAL(XPM, test x$XPM = xtrue) 427AM_CONDITIONAL(XPM, test x$XPM = xtrue)
428 428
429dnl Check whether to use imlib2
429IMLIB2=false 430IMLIB2=false
430AC_MSG_CHECKING([whether to have Imlib2 (pixmap themes) support]) 431AC_MSG_CHECKING([whether to have Imlib2 (pixmap themes) support])
431AC_ARG_ENABLE(imlib2, 432AC_ARG_ENABLE(imlib2,
432[ --enable-imlib2 Imlib2 (pixmap themes) support [default=no]]) 433 AC_HELP_STRING([--enable-imlib2],
433 434 [Imlib2 (pixmap themes) support [default=no]]), ,
434if test "x$enableval" = "xyes"; then 435 [enable_imlib2=no])
435 AC_MSG_RESULT([yes]) 436if test x$enable_imlib2 = "xyes"; then
436 AC_PATH_GENERIC(imlib2, 1.0.0, 437 AC_MSG_RESULT([yes])
437 [ 438 AC_PATH_GENERIC(imlib2, 1.0.0,
439 [
438 IMLIB2=true 440 IMLIB2=true
439 AC_DEFINE(HAVE_IMLIB2, [], [Imlib2 support]) 441 AC_DEFINE(HAVE_IMLIB2, [], [Imlib2 support])
440 IMLIB2_LIBS=`imlib2-config --libs` 442 IMLIB2_LIBS=`imlib2-config --libs`
441 IMLIB2_CFLAGS=`imlib2-config --cflags` 443 IMLIB2_CFLAGS=`imlib2-config --cflags`
442 LIBS="$LIBS $IMLIB2_LIBS" 444 LIBS="$LIBS $IMLIB2_LIBS"
443 CXXFLAGS="$CXXFLAGS $IMLIB2_CFLAGS" 445 CXXFLAGS="$CXXFLAGS $IMLIB2_CFLAGS"
444 ], 446 ], [ AC_MSG_RESULT(no)]
445 [ 447 )
446 AC_MSG_RESULT(no)
447 ])
448else 448else
449 AC_MSG_RESULT([no]) 449 AC_MSG_RESULT([no])
450fi 450fi
451 451
452AM_CONDITIONAL(IMLIB2, test x$IMLIB2 = xtrue) 452AM_CONDITIONAL(IMLIB2, test x$IMLIB2 = xtrue)
453 453
454 454
455
455AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) 456AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support])
456AC_ARG_ENABLE( 457AC_ARG_ENABLE(
457 xmb, 458 xmb,
@@ -493,7 +494,7 @@ dnl Check for Xinerama support
493AC_MSG_CHECKING([whether to build support for the Xinerama extension]) 494AC_MSG_CHECKING([whether to build support for the Xinerama extension])
494AC_ARG_ENABLE( 495AC_ARG_ENABLE(
495 xinerama, 496 xinerama,
496[ --enable-xinerama enable xinerama extension [default=no]], 497[ --enable-xinerama enable xinerama extension [default=no]],
497 if test x$enableval = "xyes"; then 498 if test x$enableval = "xyes"; then
498 AC_MSG_RESULT([yes]) 499 AC_MSG_RESULT([yes])
499 AC_CHECK_LIB(Xinerama, XineramaQueryScreens, 500 AC_CHECK_LIB(Xinerama, XineramaQueryScreens,