aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorfluxgen <fluxgen>2002-12-08 13:02:38 (GMT)
committerfluxgen <fluxgen>2002-12-08 13:02:38 (GMT)
commit1d4933a654d120707de1121a06e2927e1870934b (patch)
tree4eda40476fbb00ca1b517d5bdb45709eb0d66016 /configure.in
parenta64796680e8971a03fc9a984cae55f8d76d6cc52 (diff)
downloadfluxbox-1d4933a654d120707de1121a06e2927e1870934b.zip
fluxbox-1d4933a654d120707de1121a06e2927e1870934b.tar.bz2
fixed better xft checking
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in45
1 files changed, 16 insertions, 29 deletions
diff --git a/configure.in b/configure.in
index 72d514f..c754c83 100644
--- a/configure.in
+++ b/configure.in
@@ -221,39 +221,26 @@ AC_ARG_ENABLE(
221AM_CONDITIONAL(GNOME, test x$GNOME = xtrue) 221AM_CONDITIONAL(GNOME, test x$GNOME = xtrue)
222 222
223AC_MSG_CHECKING([whether to have Xft support]) 223AC_MSG_CHECKING([whether to have Xft support])
224AC_ARG_ENABLE( 224AM_PATH_XFT(yes,
225 xft, 225 XFT=true,
226[ --enable-xft Xft (antialias) support [default=yes]],
227 if test x$enableval = "xyes"; then
228 AC_CHECK_LIB(Xft, XftFontOpen,
229 LIBS="$LIBS -lXft"
230 XFT=true
231 AC_DEFINE(USE_XFT, 1, "antialias support"),
232 AC_MSG_RESULT([no])
233 XFT=false
234 )
235 AC_CHECK_LIB(Xft, XftDrawStringUtf8,
236 LIBS="$LIBS -lXft"
237 AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support"),
238 )
239 else
240 AC_MSG_RESULT([no])
241 XFT=false
242 fi,
243 AC_CHECK_LIB(Xft, XftFontOpen,
244 LIBS="$LIBS -lXft"
245 XFT=true
246 AC_DEFINE(USE_XFT, 1, "antialias support"),
247 AC_MSG_RESULT([no])
248 XFT=false 226 XFT=false
249 )
250 AC_CHECK_LIB(Xft, XftDrawStringUtf8,
251 LIBS="$LIBS -lXft"
252 AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support"),
253 )
254) 227)
228
229if test "x$XFT" = "xtrue" ; then
230 AC_DEFINE(USE_XFT, 1, "antialias support")
231 AC_MSG_CHECKING([Xft UTF-8 support])
232 AC_TRY_LINK([
233 #include <X11/Xft/Xft.h>
234 ], [ XftDrawStringUtf8(0, 0, 0, 0, 0, 0, 0); return 0; ],
235 AC_DEFINE(HAVE_XFT_UTF8_STRING, 1, "Xft UTF8 support")
236 AC_MSG_RESULT(yes),
237 AC_MSG_RESULT(no)
238 )
239fi
240
255AM_CONDITIONAL(XFT, test x$XFT = xtrue) 241AM_CONDITIONAL(XFT, test x$XFT = xtrue)
256 242
243
257AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) 244AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support])
258AC_ARG_ENABLE( 245AC_ARG_ENABLE(
259 xmb, 246 xmb,