aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathias Gumz <akira@fluxbox.org>2016-11-05 21:34:21 (GMT)
committerMathias Gumz <akira@fluxbox.org>2016-11-05 21:38:47 (GMT)
commit61e951617ce7983cfb6ba476d0db290bfd0a5c3e (patch)
treea1b9ae6f411fb9260997e6d6477e5ff46fb988ec /configure.ac
parent4bab7afaa4943bb627c25ec4e55e383c39dd14bd (diff)
downloadfluxbox-61e951617ce7983cfb6ba476d0db290bfd0a5c3e.zip
fluxbox-61e951617ce7983cfb6ba476d0db290bfd0a5c3e.tar.bz2
add automake helpers to enforce --std=cxx11
switching to std::unique_ptr<> in 52c9f62 caused some trouble for users of "older" compilers: they needed to add the --std=cxx11 flag by hand. to make life more convenient, m4/ax_cxx_compile_stdcxx.m4 and m4/ax_cxx_compile_stdcxx_11.m4 are added to do the right thing. in my tests, the last "good" compiler is gcc-4.8, gcc-4.7 does not support the required c++11 standard. clang++-3.5 also works.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 61be8e5..5e8d093 100644
--- a/configure.ac
+++ b/configure.ac
@@ -14,6 +14,7 @@ dnl Determine default prefix
14AS_IF([test "x$prefix" = "xNONE"], [prefix="$ac_default_prefix"]) 14AS_IF([test "x$prefix" = "xNONE"], [prefix="$ac_default_prefix"])
15 15
16AC_LANG_CPLUSPLUS 16AC_LANG_CPLUSPLUS
17AX_CXX_COMPILE_STDCXX_11([ext], [mandatory])
17 18
18dnl Locate required external software 19dnl Locate required external software
19AC_PROG_CC 20AC_PROG_CC