aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathias Gumz <akira@fluxbox.org>2015-01-04 15:21:02 (GMT)
committerMathias Gumz <akira@fluxbox.org>2015-01-04 15:21:02 (GMT)
commit0820bcb640e9030a99a4c47119df6b9305e632da (patch)
treee040502e0c5a058e8544f5235e99c04d054c0eab /configure.ac
parentad968e32b30ee6262574bc3e02b20d5b117f5b88 (diff)
downloadfluxbox-0820bcb640e9030a99a4c47119df6b9305e632da.zip
fluxbox-0820bcb640e9030a99a4c47119df6b9305e632da.tar.bz2
Fix build-system: use xxx_LDADD instead of xxx_LDFLAGS
xxx_LDFLAGS place the libraries like '-lX11' or '-lXft' at the beginning of the linker command. Some systems were not able to handle the situation and this lead to a lot of unresolved symbols. Reading the documentation of automake: ... you can use LDADD to do so. This variable is used to specify additional objects or libraries to link with; it is inappropriate for specifying specific linker flags, you should use AM_LDFLAGS for this purpose. In addition we link against -lm in order to satisfy symbols refering to 'cos' and 'sin'.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 65ee23e..33217ad 100644
--- a/configure.ac
+++ b/configure.ac
@@ -129,6 +129,10 @@ AC_CHECK_FUNCS([ \
129 vsnprintf \ 129 vsnprintf \
130]) 130])
131 131
132AC_CHECK_LIBM
133AC_SUBST(LIBM)
134LIBS="$LIBS $LIBM"
135
132dnl Windows requires the mingw-catgets library for the catgets function. 136dnl Windows requires the mingw-catgets library for the catgets function.
133AC_SEARCH_LIBS([catgets], [catgets], [], []) 137AC_SEARCH_LIBS([catgets], [catgets], [], [])
134 138