aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMathias Gumz <akira at fluxbox dot org>2013-01-10 11:11:24 (GMT)
committerMathias Gumz <akira at fluxbox dot org>2013-01-10 11:11:24 (GMT)
commit06655f6d7ff2af0626d37f083b927af2af1be529 (patch)
tree484f8d0ab80e642b2b2a3bef02b6a045903e564e /configure.ac
parent79fe2fca1de5140f538e68f6981b27cf7f917e7a (diff)
downloadfluxbox-06655f6d7ff2af0626d37f083b927af2af1be529.zip
fluxbox-06655f6d7ff2af0626d37f083b927af2af1be529.tar.bz2
Optional removal of SystemTray tool
Added the option to remove the SystemTray tool completely from fluxbox.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 226510d..cd6816f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -265,11 +265,23 @@ AS_IF(test "x$enable_slit" = "xyes",[AC_DEFINE(USE_SLIT, 1, " compile with slit"
265AM_CONDITIONAL(SLIT_SRC, test "x$enable_slit" = "xyes") 265AM_CONDITIONAL(SLIT_SRC, test "x$enable_slit" = "xyes")
266 266
267 267
268
269dnl Check for Systemtray options
270AC_MSG_CHECKING([whether to include SystemTray])
271AC_ARG_ENABLE(systray,
272 AS_HELP_STRING([--enable-systray],[include SystemTray (default=yes)]),,[enable_systray=yes])
273AC_MSG_RESULT([$enable_systray])
274AS_IF(test "x$enable_systray" = "xyes",[AC_DEFINE(USE_SYSTRAY, 1, " compile with systemtray")],[])
275AM_CONDITIONAL(SYSTRAY_SRC, test "x$enable_systray" = "xyes")
276
268dnl Check for Toolbar options 277dnl Check for Toolbar options
269AC_MSG_CHECKING([whether to include Toolbar]) 278AC_MSG_CHECKING([whether to include Toolbaddr])
270AC_ARG_ENABLE(toolbar, 279AC_ARG_ENABLE(toolbar,
271 AS_HELP_STRING([--enable-toolbar],[include Toolbar (default=yes)]),,[enable_toolbar=yes]) 280 AS_HELP_STRING([--enable-toolbar],[include Toolbar (default=yes)]),,[enable_toolbar=yes])
272AC_MSG_RESULT([$enable_toolbar]) 281AC_MSG_RESULT([$enable_toolbar])
282AS_IF(test "x$enable_systray" = "xyes" -a "x$enable_toolbar" != "xyes",[
283 AC_MSG_RESULT([disabled toolbar, but enabled systray => reenable toolbar])
284 AS_VAR_SET(enable_toolbar, "yes")],[])
273AS_IF(test "x$enable_toolbar" = "xyes",[AC_DEFINE(USE_TOOLBAR, 1, " compile with toolbar")],[]) 285AS_IF(test "x$enable_toolbar" = "xyes",[AC_DEFINE(USE_TOOLBAR, 1, " compile with toolbar")],[])
274AM_CONDITIONAL(TOOLBAR_SRC, test "x$enable_toolbar" = "xyes") 286AM_CONDITIONAL(TOOLBAR_SRC, test "x$enable_toolbar" = "xyes")
275 287