aboutsummaryrefslogtreecommitdiff
path: root/nls/ja_JP/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nls/ja_JP/Makefile.am')
-rw-r--r--nls/ja_JP/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/nls/ja_JP/Makefile.am b/nls/ja_JP/Makefile.am
new file mode 100644
index 0000000..de48ab7
--- /dev/null
+++ b/nls/ja_JP/Makefile.am
@@ -0,0 +1,28 @@
1NLSTEST = @NLS@
2CLEANFILES = blackbox.cat
3MAINTAINERCLEANFILES = Makefile.in Translation.m
4MFILES = BaseDisplay.m Basemenu.m Configmenu.m Icon.m Image.m Screen.m Slit.m Toolbar.m Window.m Windowmenu.m Workspace.m Workspacemenu.m blackbox.m common.m main.m bsetroot.m
5EXTRA_DIST=$(MFILES)
6all-local: blackbox.cat
7install-data-local: blackbox.cat
8 @if test x$(NLSTEST) = "x-DNLS"; then \
9 echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/ja_JP"; \
10 $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/ja_JP; \
11 $(INSTALL_DATA) blackbox.cat $(DESTDIR)$(pkgdatadir)/nls/ja_JP; \
12 fi
13uninstall-local:
14 @if test x$(NLSTEST) = "x-DNLS"; then \
15 rm -f $(DESTDIR)$(pkgdatadir)/nls/ja_JP/blackbox.cat; \
16 rmdir $(DESTDIR)$(pkgdatadir)/nls/ja_JP; \
17 fi
18
19Translation.m: $(MFILES)
20 @if test x$(NLSTEST) = "x-DNLS"; then \
21 rm -f Translation.m; \
22 awk -f ../convert.awk output=Translation.m $(MFILES); \
23 fi
24
25blackbox.cat: Translation.m
26 @if test x$(NLSTEST) = "x-DNLS"; then \
27 LANG=ja_JP $(gencat_cmd) blackbox.cat Translation.m; \
28 fi