aboutsummaryrefslogtreecommitdiff
path: root/util/fbcompose/plugins/xrender/fade/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'util/fbcompose/plugins/xrender/fade/Makefile.am')
-rw-r--r--util/fbcompose/plugins/xrender/fade/Makefile.am38
1 files changed, 38 insertions, 0 deletions
diff --git a/util/fbcompose/plugins/xrender/fade/Makefile.am b/util/fbcompose/plugins/xrender/fade/Makefile.am
new file mode 100644
index 0000000..2ab620c
--- /dev/null
+++ b/util/fbcompose/plugins/xrender/fade/Makefile.am
@@ -0,0 +1,38 @@
1## Makefile.am file for the fluxbox compositor.
2
3# Copyright (c) 2011 Gediminas Liktaras (gliktaras at gmail dot com)
4#
5# Permission is hereby granted, free of charge, to any person obtaining a copy
6# of this software and associated documentation files (the "Software"), to deal
7# in the Software without restriction, including without limitation the rights
8# to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
9# copies of the Software, and to permit persons to whom the Software is
10# furnished to do so, subject to the following conditions:
11#
12# The above copyright notice and this permission notice shall be included in
13# all copies or substantial portions of the Software.
14#
15# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
16# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
17# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
18# AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
19# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
20# OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
21# THE SOFTWARE.
22
23FBCOMPOSE_PATH = @FBCOMPOSE_PATH@
24
25AM_CXXFLAGS = -Wall -Wextra -pedantic -fPIC
26AM_LDFLAGS = -export-dynamic -shared -module -avoid-version
27
28INCLUDES = -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk -I$(top_srcdir)/util/fbcompose
29
30
31plugindir = $(FBCOMPOSE_PATH)/plugins/xrender
32plugin_LTLIBRARIES = fade.la
33fade_la_LIBADD = $(top_builddir)/src/FbTk/libFbTk.a
34fade_la_SOURCES = FadePlugin.hh FadePlugin.cc
35
36
37$(top_builddir)/src/FbTk/libFbTk.a:
38 cd $(top_builddir)/src/FbTk && make