aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in139
1 files changed, 137 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 14f1993..6a9aba1 100644
--- a/configure.in
+++ b/configure.in
@@ -2,6 +2,16 @@ dnl Initialize autoconf and automake
2AC_INIT(src/main.cc) 2AC_INIT(src/main.cc)
3AC_PREREQ(2.52) 3AC_PREREQ(2.52)
4AM_INIT_AUTOMAKE(fluxbox,1.3.2, no-define) 4AM_INIT_AUTOMAKE(fluxbox,1.3.2, no-define)
5LT_INIT
6
7dnl Force autoconf to not set CFLAGS and CXXFLAGS.
8if test "x$CFLAGS" = "x"; then
9 ${CFLAGS=""}
10fi
11
12if test "x$CXXFLAGS" = "x"; then
13 ${CXXFLAGS=""}
14fi
5 15
6dnl Determine default prefix 16dnl Determine default prefix
7test x$prefix = "xNONE" && prefix="$ac_default_prefix" 17test x$prefix = "xNONE" && prefix="$ac_default_prefix"
@@ -296,13 +306,13 @@ AC_ARG_ENABLE(
296AM_CONDITIONAL(NEWWMSPEC, test x$NEWWMSPEC = xtrue) 306AM_CONDITIONAL(NEWWMSPEC, test x$NEWWMSPEC = xtrue)
297 307
298dnl Check whether to include debugging code 308dnl Check whether to include debugging code
299DEBUG="" 309DEBUG="-O2"
300AC_MSG_CHECKING([whether to include verbose debugging code]) 310AC_MSG_CHECKING([whether to include verbose debugging code])
301AC_ARG_ENABLE(debug, 311AC_ARG_ENABLE(debug,
302 [ --enable-debug include verbose debugging code ([default=no])], 312 [ --enable-debug include verbose debugging code ([default=no])],
303 if test x$enableval = "xyes"; then 313 if test x$enableval = "xyes"; then
304 AC_MSG_RESULT([yes]) 314 AC_MSG_RESULT([yes])
305 DEBUG="-DDEBUG -Wall" 315 DEBUG="-DDEBUG -Wall -g -O0"
306 else 316 else
307 AC_MSG_RESULT([no]) 317 AC_MSG_RESULT([no])
308 fi, 318 fi,
@@ -624,6 +634,111 @@ else
624fi 634fi
625 635
626 636
637dnl Check for compositor features.
638
639enableval="yes"
640AC_MSG_CHECKING([whether fbcompose should be built])
641AC_ARG_ENABLE(fbcompose,
642 AC_HELP_STRING([--enable-fbcompose],
643 [build the fluxbox compositor [default=yes]]), ,
644 [enableval=yes])
645if test "x$enableval" = "xyes"; then
646 AC_MSG_RESULT([yes])
647 BUILD_FBCOMPOSE=true
648else
649 AC_MSG_RESULT([no])
650 BUILD_FBCOMPOSE=false
651fi
652AM_CONDITIONAL(BUILD_FBCOMPOSE, test x$BUILD_FBCOMPOSE = xtrue)
653
654
655if test "x$BUILD_FBCOMPOSE" = "xtrue"; then
656 AC_CHECK_LIB([Xcomposite],[XCompositeRedirectSubwindows])
657 LDFLAGS="$LDFLAGS -export-dynamic"
658
659 AC_CHECK_HEADERS([ctime time.h], [break;], [AC_MSG_ERROR([Could not find neither ctime nor time.h headers.])])
660 AC_CHECK_HEADER([sys/time.h], , [AC_MSG_ERROR([Could not find sys/time.h header.])])
661fi
662
663
664enableval="yes"
665AC_MSG_CHECKING([whether to have XRender compositing support])
666AC_ARG_ENABLE(xrender-compositing,
667 AC_HELP_STRING([--enable-xrender-compositing],
668 [XRender support for fbcompose [default=yes]]), ,
669 [enableval=yes])
670if test "x$enableval" = "xyes" -a "x$BUILD_FBCOMPOSE" = "xtrue"; then
671 AC_MSG_RESULT([yes])
672 AC_CHECK_LIB([dl], [dlopen],
673 [AC_DEFINE(HAVE_DL, [1], [Define to 1 if you have DL.])],
674 [AC_MSG_ERROR([Could not find DL library.])])
675 AC_CHECK_LIB([Xdamage], [XDamageCreate],
676 [AC_DEFINE(HAVE_XDAMAGE, [1], [Define to 1 if you have XDamage.])],
677 [AC_MSG_ERROR([Could not find X damage extension.])])
678 AC_CHECK_LIB([Xrender], [XRenderCreatePicture],
679 [AC_DEFINE(HAVE_XRENDER, [1], [Define to 1 if you have XRender.])],
680 [AC_MSG_ERROR([Could not find X render extension.])])
681 AC_CHECK_LIB([Xfixes], [XFixesCreateRegion],
682 [AC_DEFINE(HAVE_XFIXES,[1],[Define to 1 if you have XFixes.])],
683 [AC_MSG_ERROR([Could not find X fixes extension.])])
684 AC_CHECK_LIB([Xext], [XShapeCombineShape],
685 [AC_DEFINE(SHAPE,[1],[Define to 1 if you have SHAPE.])],
686 [AC_MSG_ERROR([Could not find X shape extension.])])
687 AC_DEFINE(USE_XRENDER_COMPOSITING, [1], [Define to 1 if you want XRender compositing.])
688 LIBS="$LIBS -ldl -lXext -lXdamage -lXrender -lXfixes"
689 XRENDER_COMPOSITING=true
690else
691 AC_MSG_RESULT([no])
692 XRENDER_COMPOSITING=false
693fi
694AM_CONDITIONAL(XRENDER_COMPOSITING, test x$XRENDER_COMPOSITING = xtrue)
695
696
697enableval="yes"
698AC_MSG_CHECKING([whether to have OpenGL compositing support])
699AC_ARG_ENABLE(opengl-compositing,
700 AC_HELP_STRING([--enable-opengl-compositing],
701 [OpenGL support for fbcompose [default=yes]]), ,
702 [enableval=yes])
703if test "x$enableval" = "xyes" -a "x$BUILD_FBCOMPOSE" = "xtrue"; then
704 AC_MSG_RESULT([yes])
705 AC_CHECK_LIB([dl], [dlopen],
706 [AC_DEFINE(HAVE_DL, [1], [Define to 1 if you have DL.])],
707 [AC_MSG_ERROR([Could not find DL library.])])
708 AC_CHECK_LIB([GL], [glXMakeCurrent],
709 [AC_DEFINE(HAVE_GL, [1], [Define to 1 if you have GL.])],
710 [AC_MSG_ERROR([Could not find OpenGL/GLX.])])
711 AC_CHECK_LIB([GLEW], [glewInit],
712 [AC_DEFINE(HAVE_GLEW,[1],[Define to 1 if you have GLEW.])],
713 [AC_MSG_ERROR([Could not find GLEW.])])
714 AC_CHECK_LIB([Xdamage], [XDamageCreate],
715 [AC_DEFINE(HAVE_XDAMAGE, [1], [Define to 1 if you have XDamage.])],
716 [AC_MSG_ERROR([Could not find X damage extension.])])
717 AC_CHECK_LIB([Xrender], [XRenderCreatePicture],
718 [AC_DEFINE(HAVE_XRENDER, [1], [Define to 1 if you have XRender.])],
719 [AC_MSG_ERROR([Could not find X render extension.])])
720 AC_CHECK_LIB([Xfixes], [XFixesCreateRegion],
721 [AC_DEFINE(HAVE_XFIXES,[1],[Define to 1 if you have XFixes.])],
722 [AC_MSG_ERROR([Could not find X fixes extension.])])
723 AC_CHECK_LIB([Xext], [XShapeCombineShape],
724 [AC_DEFINE(SHAPE,[1],[Define to 1 if you have SHAPE.])],
725 [AC_MSG_ERROR([Could not find X shape extension.])])
726 AC_DEFINE(USE_OPENGL_COMPOSITING, [1], [Define to 1 if you want OpenGL compositing.])
727 LIBS="$LIBS -ldl -lXext -lXdamage -lGL -lGLEW -lXfixes"
728 OPENGL_COMPOSITING=true
729else
730 AC_MSG_RESULT([no])
731 OPENGL_COMPOSITING=false
732fi
733AM_CONDITIONAL(OPENGL_COMPOSITING, test x$OPENGL_COMPOSITING = xtrue)
734
735
736if test x$OPENGL_COMPOSITING = xfalse -a x$XRENDER_COMPOSITING = xfalse; then
737 AM_CONDITIONAL(SERVERAUTO_COMPOSITING_ONLY, true)
738 AC_DEFINE(SERVERAUTO_COMPOSITING_ONLY, [1], [Set to 1 only if both OPENGL_COMPOSITING and XRENDER_COMPOSITING are undefined or 0.])
739else
740 AM_CONDITIONAL(SERVERAUTO_COMPOSITING_ONLY, false)
741fi
627 742
628 743
629 744
@@ -695,6 +810,18 @@ AC_ARG_WITH(
695) 810)
696AC_SUBST(LOCALE_PATH) 811AC_SUBST(LOCALE_PATH)
697 812
813AC_ARG_WITH(
814 fbcompose,
815 [ --with-fbcompose=path location of fbcompose files (PREFIX/share/fluxbox/fbcompose)]
816 ,
817 FBCOMPOSE_PATH=$with_fbcompose
818 AC_DEFINE_UNQUOTED(FBCOMPOSE_PATH, "$FBCOMPOSE_PATH", "Location of fbcompose data")
819 ,
820 FBCOMPOSE_PATH=\$\(prefix\)/share/fluxbox/fbcompose
821 AC_DEFINE_UNQUOTED(FBCOMPOSE_PATH, "$prefix/share/fluxbox/fbcompose", "Location of fbcompose data"),
822)
823AC_SUBST(FBCOMPOSE_PATH)
824
698AC_SUBST(program_prefix) 825AC_SUBST(program_prefix)
699AC_SUBST(program_suffix) 826AC_SUBST(program_suffix)
700 827
@@ -713,6 +840,14 @@ src/Makefile
713src/FbTk/Makefile 840src/FbTk/Makefile
714src/tests/Makefile 841src/tests/Makefile
715util/Makefile 842util/Makefile
843util/fbcompose/Makefile
844util/fbcompose/plugins/Makefile
845util/fbcompose/plugins/opengl/Makefile
846util/fbcompose/plugins/opengl/fade/Makefile
847util/fbcompose/plugins/opengl/preview/Makefile
848util/fbcompose/plugins/xrender/Makefile
849util/fbcompose/plugins/xrender/fade/Makefile
850util/fbcompose/plugins/xrender/preview/Makefile
716util/fbrun/Makefile 851util/fbrun/Makefile
717data/Makefile 852data/Makefile
718data/styles/Makefile 853data/styles/Makefile