aboutsummaryrefslogtreecommitdiff
path: root/util/Makefile.am
diff options
context:
space:
mode:
authorPaul Tagliamonte <paultag@ubuntu.com>2011-04-15 18:48:05 (GMT)
committerPaul Tagliamonte <tag@loki.(none)>2011-09-24 15:48:47 (GMT)
commitcc5c30c9cbdce2693d284c57ae4671017bf0660c (patch)
treece85451dd72abc0dfc8475c20c86e496805110f2 /util/Makefile.am
parent0e1ee49603a565427fa833a4136c586a0e816c47 (diff)
downloadfluxbox_paul-cc5c30c9cbdce2693d284c57ae4671017bf0660c.zip
fluxbox_paul-cc5c30c9cbdce2693d284c57ae4671017bf0660c.tar.bz2
Integrating fbautostart into the Fluxbox tree.
This change merges fbautostart into fluxbox. fbautostart has been re-licensed under MIT to allow for this. I've added the util/fbautostart directory, and tweeked the build chain to include fbautostart. I've also added in a few docs. Those are the only changes outside the util/fbautostart folder. It's been noted in the ChangeLog, but fbautostart changes (since it might be a bit more "high-volume") should be maintained in util/fbautostart/ChangeLog. The XDG spec can be found at: - http://standards.freedesktop.org/autostart-spec/autostart-spec-latest.html
Diffstat (limited to 'util/Makefile.am')
-rw-r--r--util/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/util/Makefile.am b/util/Makefile.am
index d0895ae..7cf9392 100644
--- a/util/Makefile.am
+++ b/util/Makefile.am
@@ -1,5 +1,10 @@
1# util/Makefile.am for Fluxbox 1# util/Makefile.am for Fluxbox
2SUBDIRS= fbrun 2
3if USE_FBAUTOSTART
4 UTIL_FBAUTOSTART = fbautostart
5endif
6
7SUBDIRS= fbrun $(UTIL_FBAUTOSTART)
3INCLUDES= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk 8INCLUDES= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk
4bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox 9bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox
5bin_PROGRAMS= fbsetroot fluxbox-update_configs fluxbox-remote 10bin_PROGRAMS= fbsetroot fluxbox-update_configs fluxbox-remote