diff options
author | fluxgen <fluxgen> | 2007-03-30 18:14:11 (GMT) |
---|---|---|
committer | fluxgen <fluxgen> | 2007-03-30 18:14:11 (GMT) |
commit | 42d0822111c31121db450fbfcf29aeb57834e642 (patch) | |
tree | ca392af38d3a8bd3d5f461549e51655e7f2308fe /nls/fi_FI/Makefile.am | |
parent | 6e143b516ecf046bbe65ccfa8aa296544559cb9b (diff) | |
download | fluxbox_paul-42d0822111c31121db450fbfcf29aeb57834e642.zip fluxbox_paul-42d0822111c31121db450fbfcf29aeb57834e642.tar.bz2 |
added fi_FI support, thanks Pasi Juvonen
Diffstat (limited to 'nls/fi_FI/Makefile.am')
-rw-r--r-- | nls/fi_FI/Makefile.am | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/nls/fi_FI/Makefile.am b/nls/fi_FI/Makefile.am new file mode 100644 index 0000000..aae0785 --- /dev/null +++ b/nls/fi_FI/Makefile.am | |||
@@ -0,0 +1,46 @@ | |||
1 | # nls/fi_FI/Makefile.am for Fluxbox - www.fluxbox.org | ||
2 | |||
3 | THE_LANG = fi_FI | ||
4 | SRC_CODESET = ISO-8859-1 | ||
5 | DEST_CODESETS = ISO-8859-1 UTF-8 | ||
6 | |||
7 | LOCALE_PATH = @LOCALE_PATH@ | ||
8 | NLSTEST = @NLS@ | ||
9 | MFILES = Translation.m | ||
10 | GENERATED_MFILES = $(patsubst %,generated-%.m,$(DEST_CODESETS)) | ||
11 | MAINTAINERCLEANFILES = Makefile.in $(GENERATED_MFILES) | ||
12 | CATFILES = $(patsubst %,fluxbox-%.cat,$(DEST_CODESETS)) | ||
13 | |||
14 | # We distribute the generated files so that users don't need iconv | ||
15 | EXTRA_DIST= $(MFILES) $(GENERATED_MFILES) | ||
16 | CLEANFILES = $(CATFILES) | ||
17 | |||
18 | all-local: $(CATFILES) | ||
19 | install-data-local: $(CATFILES) | ||
20 | @if test x$(NLSTEST) = "x-DNLS"; then \ | ||
21 | for codeset in $(DEST_CODESETS); do \ | ||
22 | echo "Installing catalog in $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}"; \ | ||
23 | $(mkinstalldirs) $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}; \ | ||
24 | $(INSTALL_DATA) fluxbox-$${codeset}.cat $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}/fluxbox.cat; \ | ||
25 | done; \ | ||
26 | fi | ||
27 | |||
28 | # not part of the normal build process | ||
29 | translations: $(GENERATED_MFILES) | ||
30 | |||
31 | generated-%.m: Translation.m | ||
32 | iconv -f $(SRC_CODESET) -t $* Translation.m | sed s/$(SRC_CODESET)/$*/ > $@ | ||
33 | |||
34 | uninstall-local: | ||
35 | @if test x$(NLSTEST) = "x-DNLS"; then \ | ||
36 | for codeset in $(DEST_CODESETS); do \ | ||
37 | rm -f $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}/fluxbox.cat; \ | ||
38 | rmdir $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}; \ | ||
39 | done; \ | ||
40 | fi | ||
41 | |||
42 | fluxbox-%.cat: generated-%.m Translation.m | ||
43 | @if test x$(NLSTEST) = "x-DNLS"; then \ | ||
44 | echo "Creating catfile for $*"; \ | ||
45 | $(gencat_cmd) fluxbox-$*.cat generated-$*.m; \ | ||
46 | fi | ||