aboutsummaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorPaul Tagliamonte <paultag@ubuntu.com>2011-04-15 18:48:05 (GMT)
committerPaul Tagliamonte <tag@loki.(none)>2011-09-24 15:48:47 (GMT)
commitcc5c30c9cbdce2693d284c57ae4671017bf0660c (patch)
treece85451dd72abc0dfc8475c20c86e496805110f2 /configure.in
parent0e1ee49603a565427fa833a4136c586a0e816c47 (diff)
downloadfluxbox_paul-cc5c30c9cbdce2693d284c57ae4671017bf0660c.zip
fluxbox_paul-cc5c30c9cbdce2693d284c57ae4671017bf0660c.tar.bz2
Integrating fbautostart into the Fluxbox tree.
This change merges fbautostart into fluxbox. fbautostart has been re-licensed under MIT to allow for this. I've added the util/fbautostart directory, and tweeked the build chain to include fbautostart. I've also added in a few docs. Those are the only changes outside the util/fbautostart folder. It's been noted in the ChangeLog, but fbautostart changes (since it might be a bit more "high-volume") should be maintained in util/fbautostart/ChangeLog. The XDG spec can be found at: - http://standards.freedesktop.org/autostart-spec/autostart-spec-latest.html
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 15 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 1d69f34..d62b04b 100644
--- a/configure.in
+++ b/configure.in
@@ -639,9 +639,14 @@ else
639 CONFIGOPTS="$CONFIGOPTS --disable-fribidi" 639 CONFIGOPTS="$CONFIGOPTS --disable-fribidi"
640fi 640fi
641 641
642 642AC_MSG_CHECKING([whether to build support for xdg autostarting])
643 643FBAUTOSTART=0
644 644AC_ARG_ENABLE(fbautostart,
645 [ --enable-fbautostart build fbautostart (xdg autostart utility) ([default=no])],
646 AC_DEFINE(USE_FBAUTOSTART, 1, " build the fbautostart xdg autostart utility")
647 FBAUTOSTART=1
648)
649AM_CONDITIONAL(USE_FBAUTOSTART, test x$FBAUTOSTART = x1)
645 650
646AC_ARG_WITH( 651AC_ARG_WITH(
647 menu, 652 menu,
@@ -730,6 +735,7 @@ src/FbTk/Makefile
730src/tests/Makefile 735src/tests/Makefile
731util/Makefile 736util/Makefile
732util/fbrun/Makefile 737util/fbrun/Makefile
738util/fbautostart/Makefile
733data/Makefile 739data/Makefile
734data/styles/Makefile 740data/styles/Makefile
735data/styles/BlueFlux/Makefile 741data/styles/BlueFlux/Makefile
@@ -804,5 +810,11 @@ AC_MSG_RESULT([Using '$CXX' for C++ compiler.])
804AC_MSG_RESULT([Building with '$CXXFLAGS' for C++ compiler flags.]) 810AC_MSG_RESULT([Building with '$CXXFLAGS' for C++ compiler flags.])
805AC_MSG_RESULT([Building with '$LIBS' for linker flags.]) 811AC_MSG_RESULT([Building with '$LIBS' for linker flags.])
806AC_MSG_RESULT([]) 812AC_MSG_RESULT([])
813AC_MSG_RESULT([Beta Features being Built:])
814AC_MSG_RESULT([(Enable beta features with --enable-FEATURE_NAME)])
815AC_MSG_RESULT([])
816AC_MSG_RESULT([fbautostart: $FBAUTOSTART])
817AC_MSG_RESULT([])
818AC_MSG_RESULT([])
807AC_MSG_RESULT([Now build $PACKAGE with 'make']) 819AC_MSG_RESULT([Now build $PACKAGE with 'make'])
808AC_MSG_RESULT([]) 820AC_MSG_RESULT([])