diff options
Diffstat (limited to 'configure.in')
-rw-r--r-- | configure.in | 25 |
1 files changed, 13 insertions, 12 deletions
diff --git a/configure.in b/configure.in index 40acb6b..f01c9f3 100644 --- a/configure.in +++ b/configure.in | |||
@@ -426,32 +426,33 @@ AC_ARG_ENABLE( | |||
426 | 426 | ||
427 | AM_CONDITIONAL(XPM, test x$XPM = xtrue) | 427 | AM_CONDITIONAL(XPM, test x$XPM = xtrue) |
428 | 428 | ||
429 | dnl Check whether to use imlib2 | ||
429 | IMLIB2=false | 430 | IMLIB2=false |
430 | AC_MSG_CHECKING([whether to have Imlib2 (pixmap themes) support]) | 431 | AC_MSG_CHECKING([whether to have Imlib2 (pixmap themes) support]) |
431 | AC_ARG_ENABLE(imlib2, | 432 | AC_ARG_ENABLE(imlib2, |
432 | [ --enable-imlib2 Imlib2 (pixmap themes) support [default=no]]) | 433 | AC_HELP_STRING([--enable-imlib2], |
433 | 434 | [Imlib2 (pixmap themes) support [default=no]]), , | |
434 | if test "x$enableval" = "xyes"; then | 435 | [enable_imlib2=no]) |
435 | AC_MSG_RESULT([yes]) | 436 | if test x$enable_imlib2 = "xyes"; then |
436 | AC_PATH_GENERIC(imlib2, 1.0.0, | 437 | AC_MSG_RESULT([yes]) |
437 | [ | 438 | AC_PATH_GENERIC(imlib2, 1.0.0, |
439 | [ | ||
438 | IMLIB2=true | 440 | IMLIB2=true |
439 | AC_DEFINE(HAVE_IMLIB2, [], [Imlib2 support]) | 441 | AC_DEFINE(HAVE_IMLIB2, [], [Imlib2 support]) |
440 | IMLIB2_LIBS=`imlib2-config --libs` | 442 | IMLIB2_LIBS=`imlib2-config --libs` |
441 | IMLIB2_CFLAGS=`imlib2-config --cflags` | 443 | IMLIB2_CFLAGS=`imlib2-config --cflags` |
442 | LIBS="$LIBS $IMLIB2_LIBS" | 444 | LIBS="$LIBS $IMLIB2_LIBS" |
443 | CXXFLAGS="$CXXFLAGS $IMLIB2_CFLAGS" | 445 | CXXFLAGS="$CXXFLAGS $IMLIB2_CFLAGS" |
444 | ], | 446 | ], [ AC_MSG_RESULT(no)] |
445 | [ | 447 | ) |
446 | AC_MSG_RESULT(no) | ||
447 | ]) | ||
448 | else | 448 | else |
449 | AC_MSG_RESULT([no]) | 449 | AC_MSG_RESULT([no]) |
450 | fi | 450 | fi |
451 | 451 | ||
452 | AM_CONDITIONAL(IMLIB2, test x$IMLIB2 = xtrue) | 452 | AM_CONDITIONAL(IMLIB2, test x$IMLIB2 = xtrue) |
453 | 453 | ||
454 | 454 | ||
455 | |||
455 | AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) | 456 | AC_MSG_CHECKING([whether to have Xmb (multibyte font, utf-8) support]) |
456 | AC_ARG_ENABLE( | 457 | AC_ARG_ENABLE( |
457 | xmb, | 458 | xmb, |
@@ -493,7 +494,7 @@ dnl Check for Xinerama support | |||
493 | AC_MSG_CHECKING([whether to build support for the Xinerama extension]) | 494 | AC_MSG_CHECKING([whether to build support for the Xinerama extension]) |
494 | AC_ARG_ENABLE( | 495 | AC_ARG_ENABLE( |
495 | xinerama, | 496 | xinerama, |
496 | [ --enable-xinerama enable xinerama extension [default=no]], | 497 | [ --enable-xinerama enable xinerama extension [default=no]], |
497 | if test x$enableval = "xyes"; then | 498 | if test x$enableval = "xyes"; then |
498 | AC_MSG_RESULT([yes]) | 499 | AC_MSG_RESULT([yes]) |
499 | AC_CHECK_LIB(Xinerama, XineramaQueryScreens, | 500 | AC_CHECK_LIB(Xinerama, XineramaQueryScreens, |