diff options
author | Damjan Dimitrioski <damjandimitrioski@gmail.com> | 2008-06-02 09:30:41 (GMT) |
---|---|---|
committer | Mark Tiefenbruck <mark@fluxbox.org> | 2008-06-02 09:30:41 (GMT) |
commit | b7e693c42518a2558d9a18b9eab6a55122ce1f43 (patch) | |
tree | 170f0e279dd2cc42de2a95c94d28a1a9f1ff1034 /nls/mk_MK/Makefile.am | |
parent | 81d297da26d2a1c39848dbbd280fd546adc75f6b (diff) | |
download | fluxbox_lack-b7e693c42518a2558d9a18b9eab6a55122ce1f43.zip fluxbox_lack-b7e693c42518a2558d9a18b9eab6a55122ce1f43.tar.bz2 |
add macedonian translations
Diffstat (limited to 'nls/mk_MK/Makefile.am')
-rw-r--r-- | nls/mk_MK/Makefile.am | 46 |
1 files changed, 46 insertions, 0 deletions
diff --git a/nls/mk_MK/Makefile.am b/nls/mk_MK/Makefile.am new file mode 100644 index 0000000..0c839e9 --- /dev/null +++ b/nls/mk_MK/Makefile.am | |||
@@ -0,0 +1,46 @@ | |||
1 | # nls/mk_MK/Makefile.am for Fluxbox - www.fluxbox.org | ||
2 | |||
3 | THE_LANG = mk_MK | ||
4 | SRC_CODESET = UTF-8 | ||
5 | DEST_CODESETS = UTF-8 | ||
6 | |||
7 | LOCALE_PATH = @LOCALE_PATH@ | ||
8 | NLSTEST = @NLS@ | ||
9 | MFILES = Translation.m | ||
10 | GENERATED_MFILES = $(patsubst %,generated-%.m,$(DEST_CODESETS)) | ||
11 | MAINTAINERCLEANFILES = Makefile.in $(GENERATED_MFILES) | ||
12 | CATFILES = $(patsubst %,fluxbox-%.cat,$(DEST_CODESETS)) | ||
13 | |||
14 | # We distribute the generated files so that users don't need iconv | ||
15 | EXTRA_DIST= $(MFILES) $(GENERATED_MFILES) | ||
16 | CLEANFILES = $(CATFILES) | ||
17 | |||
18 | all-local: $(CATFILES) | ||
19 | install-data-local: $(CATFILES) | ||
20 | @if test x$(NLSTEST) = "x-DNLS"; then \ | ||
21 | for codeset in $(DEST_CODESETS); do \ | ||
22 | echo "Installing catalog in $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}"; \ | ||
23 | $(mkinstalldirs) $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}; \ | ||
24 | $(INSTALL_DATA) fluxbox-$${codeset}.cat $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}/fluxbox.cat; \ | ||
25 | done; \ | ||
26 | fi | ||
27 | |||
28 | # not part of the normal build process | ||
29 | translations: $(GENERATED_MFILES) | ||
30 | |||
31 | generated-%.m: Translation.m | ||
32 | iconv -f $(SRC_CODESET) -t $* Translation.m | sed s/$(SRC_CODESET)/$*/ > $@ | ||
33 | |||
34 | uninstall-local: | ||
35 | @if test x$(NLSTEST) = "x-DNLS"; then \ | ||
36 | for codeset in $(DEST_CODESETS); do \ | ||
37 | rm -f $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}/fluxbox.cat; \ | ||
38 | rmdir $(DESTDIR)$(LOCALE_PATH)/$(THE_LANG).$${codeset}; \ | ||
39 | done; \ | ||
40 | fi | ||
41 | |||
42 | fluxbox-%.cat: generated-%.m Translation.m | ||
43 | @if test x$(NLSTEST) = "x-DNLS"; then \ | ||
44 | echo "Creating catfile for $*"; \ | ||
45 | $(gencat_cmd) fluxbox-$*.cat generated-$*.m; \ | ||
46 | fi | ||