summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorMathias Gumz <akira at fluxbox dot org>2008-08-14 05:52:39 (GMT)
committerMathias Gumz <akira at fluxbox dot org>2008-08-14 05:52:39 (GMT)
commite169d33552c8e7070aa6e13da0187f2013b4cfc3 (patch)
treeae9e92c7e885791c7f47645184070cbcd441ab94 /configure.in
parentc82e7c0080f8a5c14dcf95ec92dc42f59ea9dd8b (diff)
parent91ca3bc5c8e2b892a9a81b18246f72aba7deebfd (diff)
downloadfluxbox_lack-e169d33552c8e7070aa6e13da0187f2013b4cfc3.zip
fluxbox_lack-e169d33552c8e7070aa6e13da0187f2013b4cfc3.tar.bz2
Merge branch 'master' into to_push
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in103
1 files changed, 89 insertions, 14 deletions
diff --git a/configure.in b/configure.in
index 99889fa..7fbe805 100644
--- a/configure.in
+++ b/configure.in
@@ -290,20 +290,6 @@ AC_ARG_ENABLE(
290) 290)
291AM_CONDITIONAL(NEWWMSPEC, test x$NEWWMSPEC = xtrue) 291AM_CONDITIONAL(NEWWMSPEC, test x$NEWWMSPEC = xtrue)
292 292
293dnl Check for ordered 8bpp dithering
294AC_MSG_CHECKING([whether to include Pseudocolor ordered dithering code])
295AC_ARG_ENABLE(ordered-pseudo,
296[ --enable-ordered-pseudo include code for ordered pseudocolor (8bpp)
297 dithering ([default=no])],
298 if test x$enableval = "xyes"; then
299 AC_MSG_RESULT([yes])
300 AC_DEFINE(ORDEREDPSEUDO, 1, "ordered dithering code")
301 else
302 AC_MSG_RESULT([no])
303 fi,
304 AC_MSG_RESULT([no])
305)
306
307dnl Check whether to include debugging code 293dnl Check whether to include debugging code
308DEBUG="" 294DEBUG=""
309AC_MSG_CHECKING([whether to include verbose debugging code]) 295AC_MSG_CHECKING([whether to include verbose debugging code])
@@ -538,6 +524,14 @@ AC_ARG_WITH(
538AC_SUBST(DEFAULT_MENU) 524AC_SUBST(DEFAULT_MENU)
539 525
540AC_ARG_WITH( 526AC_ARG_WITH(
527 windowmenu,
528 [ --with-windowmenu=path location windowmenu file (PREFIX/share/fluxbox/windowmenu)],
529 DEFAULT_WINDOWMENU=$with_windowmenu,
530 DEFAULT_WINDOWMENU=\$\(prefix\)/share/fluxbox/windowmenu
531)
532AC_SUBST(DEFAULT_WINDOWMENU)
533
534AC_ARG_WITH(
541 style, 535 style,
542 [ --with-style=path style by default (PREFIX/share/fluxbox/styles/bloe)], 536 [ --with-style=path style by default (PREFIX/share/fluxbox/styles/bloe)],
543 DEFAULT_STYLE=$with_style, 537 DEFAULT_STYLE=$with_style,
@@ -554,6 +548,22 @@ AC_ARG_WITH(
554AC_SUBST(DEFAULT_KEYS) 548AC_SUBST(DEFAULT_KEYS)
555 549
556AC_ARG_WITH( 550AC_ARG_WITH(
551 apps,
552 [ --with-apps=path location apps file (PREFIX/share/fluxbox/apps)],
553 DEFAULT_APPS=$with_apps,
554 DEFAULT_APPS=\$\(prefix\)/share/fluxbox/apps
555)
556AC_SUBST(DEFAULT_APPS)
557
558AC_ARG_WITH(
559 overlay,
560 [ --with-overlay=path location overlay file (PREFIX/share/fluxbox/overlay)],
561 DEFAULT_OVERLAY=$with_overlay,
562 DEFAULT_OVERLAY=\$\(prefix\)/share/fluxbox/overlay
563)
564AC_SUBST(DEFAULT_OVERLAY)
565
566AC_ARG_WITH(
557 init, 567 init,
558 [ --with-init=path location init file (PREFIX/share/fluxbox/init)], 568 [ --with-init=path location init file (PREFIX/share/fluxbox/init)],
559 DEFAULT_INIT=$with_init, 569 DEFAULT_INIT=$with_init,
@@ -649,6 +659,7 @@ nls/it_IT/Makefile
649nls/ja_JP/Makefile 659nls/ja_JP/Makefile
650nls/ko_KR/Makefile 660nls/ko_KR/Makefile
651nls/lv_LV/Makefile 661nls/lv_LV/Makefile
662nls/mk_MK/Makefile
652nls/nb_NO/Makefile 663nls/nb_NO/Makefile
653nls/nl_NL/Makefile 664nls/nl_NL/Makefile
654nls/no_NO/Makefile 665nls/no_NO/Makefile
@@ -665,3 +676,67 @@ nls/vi_VN/Makefile
665nls/zh_CN/Makefile 676nls/zh_CN/Makefile
666nls/zh_TW/Makefile 677nls/zh_TW/Makefile
667) 678)
679
680dnl autoscan suggested these as of 2cac7ddf6fb0b3c937c4ea7b55b20960e362a360
681dnl wanted by: src/ClockTool.cc:262
682AC_CHECK_FUNCS([gettimeofday])
683dnl wanted by: src/Ewmh.cc:770
684AC_CHECK_FUNCS([memset])
685dnl wanted by: src/fluxbox.cc:553
686AC_CHECK_FUNCS([mkdir])
687dnl wanted by: src/FbTk/FbString.cc:80
688AC_CHECK_FUNCS([nl_langinfo])
689dnl wanted by: src/FbCommands.cc:172
690AC_CHECK_FUNCS([putenv])
691dnl wanted by: src/FbTk/RegExp.cc:56
692AC_CHECK_FUNCS([regcomp])
693dnl wanted by: src/FbTk/Timer.cc:156
694AC_CHECK_FUNCS([select])
695dnl wanted by: src/FbCommands.cc:206
696AC_CHECK_FUNCS([setenv])
697dnl wanted by: src/WorkspaceCmd.cc:403
698AC_CHECK_FUNCS([sqrt])
699dnl wanted by: src/ClientPattern.cc:104
700AC_CHECK_FUNCS([strcasecmp])
701dnl wanted by: src/FbTk/XmbFontImp.cc:101
702AC_CHECK_FUNCS([strchr])
703dnl wanted by: src/RootTheme.cc:187
704AC_CHECK_FUNCS([strstr])
705dnl wanted by: src/Window.cc:4165
706AC_CHECK_FUNCS([strtol])
707dnl wanted by: src/Keys.cc:422
708AC_CHECK_FUNCS([strtoul])
709dnl wanted by: src/FbTk/FbString.cc:43
710AC_CHECK_HEADERS([langinfo.h])
711dnl wanted by: src/AlphaMenu.cc:51
712AC_C_CONST
713dnl wanted by: src/Window.cc:3259
714AC_C_INLINE
715dnl wanted by: src/FbTk/FileUtil.cc:117
716AC_FUNC_CLOSEDIR_VOID
717dnl wanted by: src/ClientPattern.cc:333
718AC_FUNC_ERROR_AT_LINE
719dnl wanted by: src/FbCommands.cc:144
720AC_FUNC_FORK
721dnl wanted by: src/FbTk/FbString.cc:150
722AC_FUNC_MALLOC
723dnl wanted by: src/FbTk/FbString.cc:181
724AC_FUNC_REALLOC
725dnl wanted by: src/FbTk/Timer.cc:156
726AC_FUNC_SELECT_ARGTYPES
727dnl wanted by: src/Slit.cc:1149
728AC_FUNC_STAT
729dnl wanted by: src/ClockTool.cc:273
730AC_FUNC_STRFTIME
731dnl wanted by: src/FbTk/FileUtil.hh:34
732AC_HEADER_DIRENT
733dnl wanted by: src/AlphaMenu.hh:49
734AC_HEADER_STDBOOL
735dnl wanted by: src/Keys.cc:75
736AC_HEADER_SYS_WAIT
737dnl wanted by: src/AlphaMenu.cc:37
738AC_STRUCT_TM
739dnl wanted by: src/FbCommands.cc:144
740AC_TYPE_PID_T
741dnl wanted by: src/ClientMenu.cc:128
742AC_TYPE_SIZE_T