From 5a24731d3af68f376db099d8bb8ee4d7cb581124 Mon Sep 17 00:00:00 2001
From: fluxgen <fluxgen>
Date: Fri, 16 Jan 2004 11:58:45 +0000
Subject: different window for position coordinates, patch from Junichiro Kita

---
 src/Screen.hh | 10 ++++++----
 src/Window.cc |  5 +++--
 2 files changed, 9 insertions(+), 6 deletions(-)

diff --git a/src/Screen.hh b/src/Screen.hh
index 0b606a8..8f5951e 100644
--- a/src/Screen.hh
+++ b/src/Screen.hh
@@ -22,7 +22,7 @@
 // FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
 // DEALINGS IN THE SOFTWARE.
 
-// $Id: Screen.hh,v 1.132 2004/01/11 16:05:55 fluxgen Exp $
+// $Id: Screen.hh,v 1.133 2004/01/16 11:58:45 fluxgen Exp $
 
 #ifndef	 SCREEN_HH
 #define	 SCREEN_HH
@@ -253,6 +253,7 @@ public:
     void shutdown();
     /// show position window centered on the screen with "X x Y" text
     void showPosition(int x, int y);
+    void hidePosition();
     /// show geomentry with "width x height"-text, not size of window
     void showGeometry(unsigned int width, unsigned int height);
     void hideGeometry();
@@ -351,6 +352,7 @@ private:
     bool doSkipWindow(const WinClient &winclient, int options);
 
     void renderGeomWindow();
+    void renderPosWindow();
     void updateIconMenu();
 
     ScreenSubject 
@@ -364,11 +366,11 @@ private:
 		
     FbTk::MultLayers m_layermanager;
 	
-    bool root_colormap_installed, managed, geom_visible, cycling_focus;
+    bool root_colormap_installed, managed, geom_visible, pos_visible, cycling_focus;
     GC opGC;
-    Pixmap geom_pixmap;
+    Pixmap geom_pixmap, pos_pixmap;
 
-    FbTk::FbWindow m_geom_window;
+    FbTk::FbWindow m_geom_window, m_pos_window;
 
     std::auto_ptr<FbTk::ImageControl> m_image_control;
     std::auto_ptr<FbTk::Menu> m_configmenu;
diff --git a/src/Window.cc b/src/Window.cc
index bb44b50..5f024bd 100644
--- a/src/Window.cc
+++ b/src/Window.cc
@@ -22,7 +22,7 @@
 // FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
 // DEALINGS IN THE SOFTWARE.
 
-// $Id: Window.cc,v 1.260 2004/01/16 11:41:38 fluxgen Exp $
+// $Id: Window.cc,v 1.261 2004/01/16 11:58:45 fluxgen Exp $
 
 #include "Window.hh"
 
@@ -294,6 +294,7 @@ FluxboxWindow::~FluxboxWindow() {
 
     if (moving || resizing || m_attaching_tab) {
         screen().hideGeometry();
+        screen().hidePosition();
         XUngrabPointer(display, CurrentTime);
     }
 
@@ -2811,7 +2812,7 @@ void FluxboxWindow::stopMoving() {
     }
 
 
-    screen().hideGeometry();
+    screen().hidePosition();
     XUngrabPointer(display, CurrentTime);
 	
     FbTk::App::instance()->sync(false); //make sure the redraw is made before we continue
-- 
cgit v0.11.2