From 6ea1ed8cfa2915a75479daec2b21513a11cd0cee Mon Sep 17 00:00:00 2001
From: Mark Tiefenbruck <mark@fluxbox.org>
Date: Tue, 1 Jan 2008 19:10:38 -0800
Subject: fix border width on synthetic ConfigureNotify events

---
 src/FbTk/FbWindow.cc | 7 +++----
 src/FbTk/FbWindow.hh | 3 ++-
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/src/FbTk/FbWindow.cc b/src/FbTk/FbWindow.cc
index 12492d9..12b16d9 100644
--- a/src/FbTk/FbWindow.cc
+++ b/src/FbTk/FbWindow.cc
@@ -633,7 +633,8 @@ void FbWindow::create(Window parent, int x, int y,
 
 
 void FbWindow::sendConfigureNotify(int x, int y, 
-                                   unsigned int width, unsigned int height) {
+                                   unsigned int width, unsigned int height,
+                                   unsigned int bw) {
     Display *disp = FbTk::App::instance()->display();
     XEvent event;
     event.type = ConfigureNotify;
@@ -645,9 +646,7 @@ void FbWindow::sendConfigureNotify(int x, int y,
     event.xconfigure.y = y;
     event.xconfigure.width = width;
     event.xconfigure.height = height;
-    //!! TODO
-    event.xconfigure.border_width = 1;
-    //!! TODO
+    event.xconfigure.border_width = bw;
     event.xconfigure.above = None; 
     event.xconfigure.override_redirect = false;
 
diff --git a/src/FbTk/FbWindow.hh b/src/FbTk/FbWindow.hh
index f266ec3..ae3526c 100644
--- a/src/FbTk/FbWindow.hh
+++ b/src/FbTk/FbWindow.hh
@@ -195,7 +195,8 @@ public:
     void setOpaque(unsigned char alpha);
 
     void setRenderer(FbWindowRenderer &renderer) { m_renderer = &renderer; }
-    void sendConfigureNotify(int x, int y, unsigned int width, unsigned int height);
+    void sendConfigureNotify(int x, int y, unsigned int width,
+                             unsigned int height, unsigned int bw = 0);
 
     /// forces full background change, recalcing of alpha values if necessary
     void updateBackground(bool only_if_alpha);
-- 
cgit v0.11.2