From 3ac1ab023e33487ed9b851cef9c82d144ed62bc8 Mon Sep 17 00:00:00 2001
From: Mark Tiefenbruck <mark@fluxbox.org>
Date: Thu, 11 Sep 2008 14:01:36 -0700
Subject: try to fix some weird focus issues

---
 src/fluxbox.cc | 1 +
 1 file changed, 1 insertion(+)

diff --git a/src/fluxbox.cc b/src/fluxbox.cc
index 3963d89..4a223f9 100644
--- a/src/fluxbox.cc
+++ b/src/fluxbox.cc
@@ -825,6 +825,7 @@ void Fluxbox::handleEvent(XEvent * const e) {
         // a grab is something of a pseudo-focus event, so we ignore
         // them, here we ignore some window receiving it
         if (e->xfocus.mode == NotifyGrab ||
+            e->xfocus.mode == NotifyUngrab ||
             e->xfocus.detail == NotifyPointer ||
             e->xfocus.detail == NotifyInferior)
             break;
-- 
cgit v0.11.2