From ecdaba28743069d23ea04531129e11cb9b42995d Mon Sep 17 00:00:00 2001
From: Mathias Gumz <akira at fluxbox dot org>
Date: Thu, 9 Sep 2010 23:24:27 +0200
Subject: simpler code

---
 src/fluxbox.cc | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/src/fluxbox.cc b/src/fluxbox.cc
index ea827f2..2c63ddb 100644
--- a/src/fluxbox.cc
+++ b/src/fluxbox.cc
@@ -256,10 +256,7 @@ Fluxbox::Fluxbox(int argc, char **argv, const char *dpy_name,
     // because it could affect ongoing menu stuff so we need to reconfig in
     // the next event "round".
     FbTk::RefCount<FbTk::Command<void> > reconfig_cmd(new FbTk::SimpleCommand<Fluxbox>(*this, &Fluxbox::timed_reconfigure));
-    timeval to;
-    to.tv_sec = 0;
-    to.tv_usec = 1;
-    m_reconfig_timer.setTimeout(to);
+    m_reconfig_timer.setTimeout(0, 1);
     m_reconfig_timer.setCommand(reconfig_cmd);
     m_reconfig_timer.fireOnce(true);
 
-- 
cgit v0.11.2