From 24119724db95e9cdf3a6fbc079832ff092364965 Mon Sep 17 00:00:00 2001
From: mathias <mathias>
Date: Mon, 22 Nov 2004 08:30:23 +0000
Subject: undermouseplacement .. ensure the new window is on the screen. patch
 #1052534, close #1048000

---
 src/Workspace.cc | 8 ++++----
 1 file changed, 4 insertions(+), 4 deletions(-)

diff --git a/src/Workspace.cc b/src/Workspace.cc
index b377880..4de6a37 100644
--- a/src/Workspace.cc
+++ b/src/Workspace.cc
@@ -455,14 +455,14 @@ void Workspace::placeWindow(FluxboxWindow &win) {
         if (test_x < head_left)
             test_x = head_left;
 
-        if (test_x > head_right)
-            test_x = head_right;
+        if (test_x + win_w > head_right)
+            test_x = head_right - win_w;
 
         if (test_y < head_top)
             test_y = head_top;
 
-        if (test_y > head_bot)
-            test_y = head_bot;
+        if (test_y + win_h > head_bot)
+            test_y = head_bot - win_h;
 
         place_x = test_x;
         place_y = test_y;
-- 
cgit v0.11.2