diff options
Diffstat (limited to 'util/Makefile.am')
-rw-r--r-- | util/Makefile.am | 48 |
1 files changed, 35 insertions, 13 deletions
diff --git a/util/Makefile.am b/util/Makefile.am index 296bafb..66376f4 100644 --- a/util/Makefile.am +++ b/util/Makefile.am | |||
@@ -1,17 +1,39 @@ | |||
1 | # util/Makefile.am for Blackbox 0.61.x - an X11 Window manager | 1 | # util/Makefile.am for Fluxbox |
2 | SUBDIRS= fbrun | ||
3 | INCLUDES= -I$(top_srcdir)/src -I$(top_srcdir)/src/FbTk | ||
4 | bin_SCRIPTS= fbsetbg fluxbox-generate_menu startfluxbox | ||
5 | bin_PROGRAMS= bsetroot | ||
6 | bsetroot_SOURCES= bsetroot.cc bsetroot.hh | ||
7 | bsetroot_LDADD= ../src/FbRootWindow.o ../src/I18n.o \ | ||
8 | ../src/FbAtoms.o ../src/FbTk/libFbTk.a | ||
2 | 9 | ||
3 | CPPFLAGS= @CPPFLAGS@ @DEBUG@ @NLS@ @TIMEDCACHE@ @NEWWMSPEC@ @INTERLACE@ \ | 10 | MAINTAINERCLEANFILES= Makefile.in |
4 | @ORDEREDPSEUDO@ | 11 | EXTRA_DIST= fbsetbg fluxbox-generate_menu.in \ |
12 | startfluxbox.in | ||
5 | 13 | ||
6 | bin_SCRIPTS = bsetbg | 14 | all-local: startfluxbox |
7 | bin_PROGRAMS = bsetroot | ||
8 | bsetroot_SOURCES = bsetroot.cc bsetroot.hh | ||
9 | bsetroot_LDADD = ../src/BaseDisplay.o ../src/LinkedList.o ../src/Timer.o ../src/Image.o ../src/i18n.o | ||
10 | MAINTAINERCLEANFILES = Makefile.in | ||
11 | EXTRA_DIST=bsetbg | ||
12 | 15 | ||
13 | distclean-local: | 16 | clean-local: |
14 | rm -f *\~ | 17 | rm -f startfluxbox fluxbox-generate_menu |
15 | 18 | ||
16 | bsetroot.o: bsetroot.cc ../config.h bsetroot.hh ../src/BaseDisplay.hh \ | 19 | bsetroot.o: bsetroot.cc ../config.h $(srcdir)/bsetroot.hh \ |
17 | ../src/LinkedList.hh ../src/Timer.hh ../src/Image.hh | 20 | $(top_srcdir)/src/FbRootWindow.hh $(top_srcdir)/src/FbAtoms.hh |
21 | |||
22 | startfluxbox: startfluxbox.in | ||
23 | @regex_cmd@ -e "s,@pkgdatadir@,$(pkgdatadir),g" \ | ||
24 | -e "s,@pkgbindir@,$(bindir),g" \ | ||
25 | $(srcdir)/startfluxbox.in > startfluxbox | ||
26 | -chmod 755 startfluxbox | ||
27 | |||
28 | fluxbox-generate_menu: fluxbox-generate_menu.in | ||
29 | @regex_cmd@ -e "s,@PREFIX@,$(prefix),g" \ | ||
30 | $(srcdir)/fluxbox-generate_menu.in \ | ||
31 | > fluxbox-generate_menu | ||
32 | -chmod 755 fluxbox-generate_menu | ||
33 | |||
34 | ../src/FbRootWindow.o: | ||
35 | cd ../src && ${MAKE} FbRootWindow.o | ||
36 | ../src/I18n.o: | ||
37 | cd ../src && ${MAKE} I18n.o | ||
38 | ../src/FbAtoms.o: | ||
39 | cd ../src && ${MAKE} FbAtoms.o | ||