aboutsummaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am52
1 files changed, 33 insertions, 19 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index 8e5f514..af39ccf 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,8 +1,8 @@
1# Makefile.am for fluxbox 1# Makefile.am for fluxbox
2# Copyright (c) 2001 Henrik Kinnunen (fluxgen@linuxmail.org) 2# Copyright (c) 2001 - 2003 Henrik Kinnunen (fluxgen at users.sourceforge.net)
3# 3#
4# src/Makefile.am for Blackbox 0.61.x - an X11 Window manager 4# src/Makefile.am for Blackbox 0.61.x - an X11 Window manager
5# Copyright (c) 1997 - 2000 Brad Hughes (bhughes@tcac.net) 5# Copyright (c) 1997 - 2000 Brad Hughes (bhughes at tcac.net)
6# 6#
7# Permission is hereby granted, free of charge, to any person obtaining a 7# Permission is hereby granted, free of charge, to any person obtaining a
8# copy of this software and associated documentation files (the "Software"), 8# copy of this software and associated documentation files (the "Software"),
@@ -23,33 +23,47 @@
23# DEALINGS IN THE SOFTWARE. 23# DEALINGS IN THE SOFTWARE.
24 24
25 25
26SUBDIRS= FbTk
26DEFAULT_MENU=$(pkgdatadir)/menu 27DEFAULT_MENU=$(pkgdatadir)/menu
27DEFAULT_STYLE=$(pkgdatadir)/styles/Clean 28DEFAULT_STYLE=$(pkgdatadir)/styles/Clean
28DEFAULT_TITLEBAR=$(pkgdatadir)/titlebar
29DEFAULT_KEYSFILE=$(pkgdatadir)/keys 29DEFAULT_KEYSFILE=$(pkgdatadir)/keys
30DEFAULT_INITFILE= 30DEFAULT_INITFILE=
31 31
32CPPFLAGS= -Wall @CPPFLAGS@ @SHAPE@ @SLIT@ @INTERLACE@ @ORDEREDPSEUDO@ \ 32AM_CPPFLAGS= -Wall @CPPFLAGS@ \
33@DEBUG@ @NEWWMSPEC@ @NLS@ @TIMEDCACHE@ @KDE@ @GNOME@ \
34-DLOCALEPATH=\"$(pkgdatadir)/nls\" \ 33-DLOCALEPATH=\"$(pkgdatadir)/nls\" \
35-DDEFAULTMENU=\"$(DEFAULT_MENU)\" \ 34-DDEFAULTMENU=\"$(DEFAULT_MENU)\" \
36-DDEFAULTSTYLE=\"$(DEFAULT_STYLE)\" \ 35-DDEFAULTSTYLE=\"$(DEFAULT_STYLE)\" \
37-DDEFAULTTITLEBAR=\"$(DEFAULT_TITLEBAR)\"\
38-DDEFAULTKEYSFILE=\"$(DEFAULT_KEYSFILE)\"\ 36-DDEFAULTKEYSFILE=\"$(DEFAULT_KEYSFILE)\"\
39-DDEFAULT_INITFILE=\"$(pkgdatadir)/init\" 37-DDEFAULT_INITFILE=\"$(pkgdatadir)/init\"\
38-IFbTk
40 39
41bin_PROGRAMS= fluxbox 40bin_PROGRAMS= fluxbox
42 41
43fluxbox_SOURCES= BaseDisplay.cc BaseDisplay.hh Basemenu.cc Basemenu.hh \
44 Clientmenu.cc Clientmenu.hh Configmenu.cc Configmenu.hh \
45 Icon.cc Icon.hh Image.cc Image.hh LinkedList.cc LinkedList.hh \
46 Netizen.cc Netizen.hh Rootmenu.cc Rootmenu.hh Screen.cc Screen.hh\
47 Slit.cc Slit.hh Timer.cc Timer.hh Toolbar.cc Toolbar.hh \
48 Window.cc Window.hh Windowmenu.cc Windowmenu.hh \
49 Workspace.cc Workspace.hh Workspacemenu.cc Workspacemenu.hh \
50 fluxbox.cc fluxbox.hh bsd-snprintf.c bsd-snprintf.h \
51 i18n.cc i18n.hh main.cc Tab.hh Tab.cc Keys.cc Keys.hh\
52 IconBar.cc IconBar.hh Theme.hh Theme.cc misc.hh misc.cc \
53 Rotated.hh
54MAINTAINERCLEANFILES= Makefile.in
55 42
43if NEWWMSPEC
44newwmspec_SOURCE= Ewmh.hh Ewmh.cc
45endif
46if GNOME
47gnome_SOURCE= Gnome.hh Gnome.cc
48endif
49
50fluxbox_SOURCES = AtomHandler.hh ArrowButton.hh ArrowButton.cc BaseDisplay.cc BaseDisplay.hh \
51 BoolMenuItem.hh \
52 DirHelper.hh DirHelper.cc DrawUtil.cc DrawUtil.hh ${newwmspec_SOURCE} \
53 FbAtoms.hh FbAtoms.cc FbWinFrame.hh FbWinFrame.cc FbWinFrameTheme.hh FbWinFrameTheme.cc \
54 fluxbox.cc fluxbox.hh ${gnome_SOURCE} \
55 IconBar.cc IconBar.hh \
56 i18n.cc i18n.hh \
57 Keys.cc Keys.hh main.cc \
58 Netizen.cc Netizen.hh nl_types_cygnus.h \
59 Resource.hh Resource.cc \
60 Screen.cc Screen.hh \
61 Slit.cc Slit.hh StringUtil.cc StringUtil.hh \
62 Tab.hh Tab.cc Theme.hh Theme.cc \
63 Toolbar.cc Toolbar.hh \
64 ToolbarTheme.hh ToolbarTheme.cc \
65 WinButton.hh WinButton.cc Window.cc Window.hh \
66 Workspace.cc Workspace.hh \
67 XrmDatabaseHelper.hh FbCommands.hh FbCommands.cc LayerMenu.hh \
68 IntResMenuItem.hh IntResMenuItem.cc FbMenu.hh
69LDADD=FbTk/libFbTk.a