diff options
Diffstat (limited to 'src/FbTk/Makefile.am')
-rw-r--r-- | src/FbTk/Makefile.am | 31 |
1 files changed, 31 insertions, 0 deletions
diff --git a/src/FbTk/Makefile.am b/src/FbTk/Makefile.am new file mode 100644 index 0000000..4d8318b --- /dev/null +++ b/src/FbTk/Makefile.am | |||
@@ -0,0 +1,31 @@ | |||
1 | noinst_LIBRARIES = libFbTk.a | ||
2 | |||
3 | if XFT | ||
4 | xft_SOURCE= XftFontImp.hh XftFontImp.cc | ||
5 | endif | ||
6 | if MULTIBYTE | ||
7 | xmb_SOURCE= XmbFontImp.hh XmbFontImp.cc | ||
8 | endif | ||
9 | |||
10 | libFbTk_a_SOURCES = App.hh App.cc Color.cc Color.hh Command.hh \ | ||
11 | EventHandler.hh EventManager.hh EventManager.cc \ | ||
12 | FbWindow.hh FbWindow.cc Font.cc Font.hh FontImp.hh \ | ||
13 | ImageControl.hh ImageControl.cc \ | ||
14 | MacroCommand.hh MacroCommand.cc \ | ||
15 | Menu.hh Menu.cc MenuItem.hh MenuItem.cc \ | ||
16 | MenuTheme.hh MenuTheme.cc NotCopyable.hh \ | ||
17 | RefCount.hh SimpleCommand.hh SignalHandler.cc SignalHandler.hh \ | ||
18 | Text.hh Text.cc \ | ||
19 | Texture.cc Texture.hh TextureRender.hh TextureRender.cc \ | ||
20 | Theme.hh Theme.cc Timer.hh Timer.cc \ | ||
21 | XFontImp.cc XFontImp.hh \ | ||
22 | Button.hh Button.cc \ | ||
23 | Layer.hh LayerItem.hh MultLayers.cc MultLayers.hh \ | ||
24 | XLayer.cc XLayer.hh XLayerItem.cc XLayerItem.hh \ | ||
25 | StringUtil.hh StringUtil.cc \ | ||
26 | Subject.hh Subject.cc Observer.hh Observer.cc \ | ||
27 | Transparent.hh Transparent.cc \ | ||
28 | FbPixmap.hh FbPixmap.cc \ | ||
29 | FbDrawable.hh FbDrawable.cc \ | ||
30 | ${xft_SOURCE} \ | ||
31 | ${xmb_SOURCE} | ||