aboutsummaryrefslogtreecommitdiff
path: root/nls/pt_PT/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'nls/pt_PT/Makefile.am')
-rw-r--r--nls/pt_PT/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/nls/pt_PT/Makefile.am b/nls/pt_PT/Makefile.am
new file mode 100644
index 0000000..cf35d0c
--- /dev/null
+++ b/nls/pt_PT/Makefile.am
@@ -0,0 +1,30 @@
1# nls/pt_PT/Makefile.am for Fluxbox - an X11 Window Manager
2
3NLSTEST = @NLS@
4CLEANFILES = fluxbox.cat
5MAINTAINERCLEANFILES = Makefile.in Translation.m
6MFILES = BaseDisplay.m Basemenu.m Configmenu.m Icon.m Image.m Screen.m Slit.m Toolbar.m Window.m Windowmenu.m Workspace.m Workspacemenu.m fluxbox.m common.m main.m bsetroot.m
7EXTRA_DIST=$(MFILES)
8all-local: fluxbox.cat
9install-data-local: fluxbox.cat
10 @if test x$(NLSTEST) = "x-DNLS"; then \
11 echo "Installing catalog in $(DESTDIR)$(pkgdatadir)/nls/pt_PT"; \
12 $(mkinstalldirs) $(DESTDIR)$(pkgdatadir)/nls/pt_PT; \
13 $(INSTALL_DATA) fluxbox.cat $(DESTDIR)$(pkgdatadir)/nls/pt_PT; \
14 fi
15uninstall-local:
16 @if test x$(NLSTEST) = "x-DNLS"; then \
17 rm -f $(DESTDIR)$(pkgdatadir)/nls/pt_PT/fluxbox.cat; \
18 rmdir $(DESTDIR)$(pkgdatadir)/nls/pt_PT; \
19 fi
20
21Translation.m: $(MFILES)
22 @if test x$(NLSTEST) = "x-DNLS"; then \
23 rm -f Translation.m; \
24 awk -f ../convert.awk output=Translation.m $(MFILES); \
25 fi
26
27fluxbox.cat: Translation.m
28 @if test x$(NLSTEST) = "x-DNLS"; then \
29 LANG=pt_PT $(gencat_cmd) fluxbox.cat Translation.m; \
30 fi